Sign in to follow this  
Guest Stormshadow

video card question

Recommended Posts

Heya all,I recently purchased an Abit fx5200 128 mb DDR ram video card sporting an Nvidia GPU + 8x AGP bus. Seems impressive. Next thing is, I load FS2002 and frame rates are practically unchanged from my GeForce Mx420, 64 MB RAM (4x AGP). You can imagine the frustration! My motherboard features a 4x AGP bus - could this be the key to the lack of performance?Answers, tweaking solutions appreciated!CheersStorm

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Storm,I think you may think you have taken a bigger step than you actually did. Although not a bad card, the 5200's are actually slower in most cases than the 4600 series..As far as $X vs 8X AGP. I can gaurantee you you will not see any difference running 8XAGP. Right now the 4XAGP bus is not running full so 8X is really not needed right now.You did update the drivers for the VC and your chipset drivers right?Bobby

Share this post


Link to post
Share on other sites

I have updated the Nvidia drivers to 52.16 and haven't seen any improvement. With regards to the chipset - are you referring to the actual video card hardware (exclpuding the Nvidia GPU) or main board?It beats me that a card having 128 MB DDR Ram and an enhanced GPU is slower or at most equal than a card (MX420) having 64MB of SDRAM (my motherboard sports DDR RAM)...if anything I'd expect at least a slight increase in performance!! Or is it a rip off case!? Purchased the card for around 65 pounds Sterling...Storm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this