Archived

This topic is now archived and is closed to further replies.

A Canadian Flyer

Windows Speech Problems (can train but can't launch)

Recommended Posts

I've researched this issue (thru these forums, internet search, etc) to death and am at my wit's end trying to resolve this...I've recently purchased VoxATC and am waiting for it to arrive in the mail (decided on the box version as I understand you receive additional voice packs) so thought I should make sure my PC is ready on the voice recognition front. I have used Windows 7 speech recognition before as my secondary computer (laptop) contains many FSX utilities as well as the Feelthere Tower simulation which I use with Windows 7 speech..

 

On my main FSX PC I use a headset microphone and am able to configure the microphone and "train" the speech engine using my voice. The problem lies when I try to "Start Speech Recognition", i.e. launch the speech recognition panel. The %windir%\Speech\Common\sapisvr.exe program is run (can see it in task manager) but then closes approx 10 seconds later. No events are logged in the event and no error is displayed.

 

Some of the things I've tried to resolve this issue include:

 

1. Updated the audio driver

2. Setting locale to something other than United States, reboot, setting back to United States, reboot

3. Adding a call to cftmon.exe at windows startup (a fix that worked from some)

4. Did a system restore to a checkpoint a few months prior. As I've never tried speech until now I can't be certain as to when it "broke" so this is a bit of a crap shoot that didn't work.

5. Removed my Sound Blaster X-fi sound card and reverted to onboard audio

6. Tried an inline windows update that failed to complete as it was frozen at 42% for 6 hours, this is an issue people have when trying to update/fix their windows installation.

7. Installed Office 2010 to see if any of the speech "hooks" would magically fix the problem.

8. Ensured the OS is fully patched with "windows update"

 

As speech is baked into the OS I have yet to find a downloadable program that will allow me to re-install speech and re-installing the entire OS to fix this issue would be a 2-3 day affair I'm not eager to perform.

 

Any help/tips/suggestions would very much be appreciated!!!

 

Andreas

_______________________________________

ASUS P5Q Pro Turbo * E8600 3.33 o/c 4.0 ghz * EVGA GTX 275 *

OCZ Reaper DDR2 4GB * Corsair 750W ATX * Lian-LI Case *

Windows 7 64bit

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!