Jump to content

Archived

This topic is now archived and is closed to further replies.

Guest

Recovering from G3D.DLL crashes and tips to diagnose.

Recommended Posts

Guest

In the event you get a g3d.dll crash in Prepar3D V2.x, here is a good process to follow post crash (Prepar3D.exe is not running) and BEFORE you attempt to run P3D again:

 

1.  Delete your shaders folder (.cso files could be left in a corrupted or partial written state).  Your shaders folders can be found here C:\Users\[your username goes here]\AppData\Local\Lockheed Martin\Prepar3D v2\Shaders  ... example: C:\Users\Rob\AppData\Local\Lockheed Martin\Prepar3D v2\Shaders

 

2.  Check that any executable tied to Prepar3D is still NOT running (Process explorer can show you if this is still the case).  Your EXE.XML (i.e. "C:\Users\Rob\AppData\Roaming\Lockheed Martin\Prepar3D v2\exe.xml") will list executables that get loaded when Prepar3D starts (there are some exceptions).  As an example: GoFlight modules have this entry in the EXE.XML:

  <Launch.Addon>
    <Disabled>False</Disabled>
    <Name>GoFlight FSX Data Bridge</Name>
    <ManualLoad>False</ManualLoad>
    <Path>C:\Program Files (x86)\GoFlight\GFDevP3D.exe</Path>
    <CommandLine></CommandLine>
  </Launch.Addon>

So using Process Explorer make sure you do NOT see GFDevP3D.exe still running in the process list.  If you do, kill the process, then Open GFConfig and exit GFConfig to clear any memory residence.  This example is for GoFlight, but other products that use the EXE.XML "may" operate in a similar fashion and require a similar process.

 

3.  If you run TrackIR5, make sure to shut it down and restart it.

 

4.  If you have FRAPS or some other software loaded for recording (Shadow Play, DXTory, etc.), make sure you shut that down also.

 

If you are still crashing on Prepar3D startup and have done the above, then you'll need to disable all entries in your EXE.XML and DLL.XML.  This is relatively easy to accomplish, just set Disable to True, see example:

  <Launch.Addon>
    <Name>GoFlight Module Interface</Name>
    <Disabled>True</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>C:\Program Files (x86)\GoFlight\GoFlight Interface Module.dll</Path>
  </Launch.Addon>

Once everything is disabled, and you've done steps 1 - 4 above, try to run Prepar3D again ... be aware that Prepar3D will recompile/build all the shaders so this can take some time 1-5 minutes pending your system (also a good idea to go to an external view to make sure the aircraft shaders are built also) and you screen will look odd during this process ... just be patient.

 

If Prepar3D is working again, you can can now start to re-enable items in you DLL.XML one by one (not all at the same time) check that Prepar3D works after each one is enabled.  Repeat until all is good or you find the specific entry that caused the crash.

 

But keep in mind, any time you have a G3D.DLL crash, repeat steps 1-4 above before trying to run Prepar3D again.

 

Hope this helps.

 

Cheers, Rob.

 

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...