Sign in to follow this  
Schantzplayer

2nd monitor doesn't display PDMG intruments (PFD blank)

Recommended Posts

I have a windows  system that has a Nvidia 980TX card and 2 4k monitors.  Everything plays fine on 1 monitor but when I detach instruments and drag them to the 2nd monitor, the display goes blank. I only seem to experience this with PDMG airplanes.  I have them all.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

More information is needed about your setup, but the problem you describe is unlikely to be caused by all of your PMDG aircraft.  Previous Win10 updates have caused issues with multiple displays not working properly with these cards in the past, so the first thing I suggest you check is your multiple display settings and surround spanning options.  Make sure you also have the latest Nvidia graphics driver installed for your card.  

Have a look online and in the other Avsim Forums (e.g Monitors | Multi-Monitors | Video Cards | Drivers and FSX, P3D, Win10 etc), because there is a good chance you will find an answer to your graphics issue there.

Don't forget you need to sign your posts in these forums too.

Edited by berts

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this