paradoxbox

Reinstalled P3D, simconnect appears to be unfixable? Help!

Recommended Posts

Posted (edited)

I'm at my wit's end here.

I reinstalled P3D V3 as it was a years' old installation with performance degrading and too many mods installed.

I uninstalled it completely using the uninstaller, then removed all of the remaining associated folders and files and registry entries.

I then reinstalled it onto a new SSD drive with a different drive letter.

The problems began when I tried reinstalling add ons which require simconnect to function. While the addons appear in the addon menu, their functionality is broken.

Example: FSLabs Concorde uses some gauges which interface with simconnect. After 20 or 30 minutes of flight, the INS gauges begin to freeze up and behave very strangely. They don't all go out at once but they all fail eventually. The dials can no longer be moved and the displays become frozen and garbled, it's not a simulated failure, simconnect is losing connectivity with them and they're breaking. Another thing I noticed was that when changing the fuel quantity in the FSLabs loadout menu, the "Total Fuel" quantity slider no longer adjusts the amount of fuel in all the other tanks. They can each be moved individually and the change is reflected in the aircraft, but the total fuel slider no longer does anything. This is more evidence of a simconnect issue.

Another example: ActiveSky 2016 can inject weather into the sim and it works almost perfectly, except when I try to make a Weather Request from the add-on menu in the sim, nothing happens. There is supposed to be a window pop up that lets me select from a few different options i.e. local airport, local weather station, winds aloft etc. This can't be brought up anymore.

Another example: GSX / SODE / COUATL are all running and test fine, but again, when I try to bring up the GSX window to do a pushback or loading or whatever, the window doesn't come up. But it is running and I am able to access the parking editor and aircraft editor.

 

I've tried uninstalling and reinstalling the simconnect msi's in the redist folder that come with p3d but it doesn't seem to make any difference. The problem persists even on a nearly bone-stock P3D V3 installation - just the Concorde and no other mods. I've also done a full uninstall and reinstall of all add ons and p3d itself to no avail.

I'm not running P3D networked to anything else, it's all supposed to be a self contained installation, not a networked one.  Any solutions would be welcome.

Edited by paradoxbox

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I've discovered the source of the problem.

 

It has to do with a content and client mismatch. The content that was installed during the reinstall was not matched with the client that had been installed and that was what caused the unusual behavior with the windows. I hope this helps someone out there having the same problem, I've seen it before on the GSX forums and it has frustrated the hell out of people trying to figure it out. Make sure all content, scenery, client etc. is all on matching version numbers, otherwise it will partially work but there will be mysterious behavior in certain modules.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now