Sign in to follow this  
Guest Jock in a Frock

MouseLook - Zoom not working from wheel

Recommended Posts

Hi, somehow I've buggered up the control assignment for Zoom Out in MouseLook mode. When I hold the Space bar, I can zoom in with mousewheel up, but mousewheel down does not zoom back out. I know it used to, and I think I screwed it up when I was making some other changes.I've been all through the control assignments, but can't find this setting to re-assign it to mousewheel down. Any ideas?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The easiest option might be resetting all control to default.

Share this post


Link to post
Share on other sites

Yeah, I could do that but it's like using a sledge-hammer to crack a nut!Surely this setting is stored somewhere and can be reset properly.....

Share this post


Link to post
Share on other sites

Er... how else do you crack a nut...?;)Go to the Settings page of FS X and choose Controls... (on the right, under Other settings), select Buttons/Keys and select from the controller type popup menu Mouse Look. Scroll up and down the list and look for an entry called 'Mouse Wheel Down' in the Joystick (!!!) part of the list. If it is there, delete it by clicking on Delete Joystick (!) Assignement. If is is not there, select from the controller type popup menu Mouse Yoke and look in the Joystick list once again. You can ONLY assign the mouse wheel to functions on the Buttons/Keys page and you can ONLY do that (and they will ONLY show up too, in the Joystick list) when you've chosen Mouse Look or Mouse Yoke. So you do not have to look for 'Mouse Wheel Down' anywhere else: it's GOT to be in one of those two lists. You won't see the entry 'Mouse Wheel Down' if you've got the joystick, or whatever controller you have, selected in the controller type menu. Hope this helps!P.S. BTW AFAIK when you click on Reset Defaults ONLY the settings you actually see will be reset. So when you've got Mouse Look showing and you click on Reset Default, anything you've changed with other controllers will remain as they are (correct me if I'm wrong). So resetting isn't really a sledgehammer: it's a tiny and quit precise hammer. :)

Share this post


Link to post
Share on other sites

Mouse Wheel Down is not there, it's not assigned to anything! I had already looked, and I was aware that I had to select the corret controller type in the settings screen.Also, you said "reset all the controls" - and that is not a tiny and quite precise hammer, it's a wrecking ball. ;)Thanks for your suggestions, anyway.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this