Sign in to follow this  
Guest SoarPics

'Jumpy' frame rates in FSX

Recommended Posts

Some time ago, in the usual quest to get more performance out of FSX, I installed new ATI/catalyst drivers - and while the sim performs better in many respects, I find my frame rates jump around a lot - and I mean from like 6FPS to 35FPS and back, and on a very quick cycle. I can't fully attribute this to the new drivers, since at the time I was messing with a lot of things (as I think many of us do!!! LOL) so really I was wondering....Does anyone else experience this type of thing? I didn't seem to notice it with my older drivers. I've tried setting it to lock at say 20FPS, but it just degrades performance (as I know many see) --- but at unlimited, the jumpy rate is really noticable, one moment it's smooth, next it's - well let's say, jumpy, then back to smooth.Does anyone have ideas on specific sim/config setting ideas, or graphics card settings that might improve this? I only have 128MB of graphics RAM, and know I am close to maxing it (though I have tried to tune things to keep it in the limit - mainly by turning autogen off/right down).Honestly I try not to be a frame rate watcher - but the sudden changes are really noticable when flying.All ideas and input appreciated :)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Do you use hotkeys to adjust features on your VC on the fly? I don't know of too many folks who do, and if not then you should disable the ATI Hotkey Poller (and ATI Smart while you're there) services.Setting an unlimited framerate will often lead to jumpy rates. What happens to the framerate when you do lock it (forget for the purpose of this test that the graphics aren't what you like... try a test just to see what the FR does)?This problem could also be caused by some other service or .exe hitting your resources. You can monitor these possibilities using Perfmon.Finally, Regmon can be used to see just what FS is calling while you're flying.You can Google Perfmon and Regmon for downloading. They are freeware.Hope this helps,

Share this post


Link to post
Share on other sites

Hi Greg,Thanks for your input.Firstly I'll say, the machine I currently run FSX on is my software development box (since it's the quickest, 2.8GHZ HT, 2GB RAM etc.) though when I run FSX I make sure there is nothing else competing for CPU or other resources (stop all the services down to the bare minimum and other things loaded at startup) and I do use perfmon to help with my tuning of FSX, and also other tools to monitor graphics RAM usage (which I know is one of my biggest limitations since this machine only has 128MB dedicated).That said - I had overlooked the ATI Hotkey Poller - I don't use it, and it was turned on even in my startup mode for FSX. Well I killed the exe that handles that, and honestly the difference was amazing, it really smoothed things out, 20-30+FPS with unlimited and about 17-25FPS with it set locked at 25. And that's with pretty good display settings in the simulator too.Many thanks - I never would in a million years of thought of something so basic having such an effect!!!! Great bit of advice.Andy.

Share this post


Link to post
Share on other sites

Great news, Andy.Keep in mind that each time you install new ATI drivers ATI Hotkey Poller and ATI Smart will be enabled again (they must be disabled after each driver install).Cheers,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this