Jump to content
Sign in to follow this  

Hotas One not recognized after startup

Recommended Posts

Hello everybody

Merry Christmas and a happy, Covid-free new year!

I bought a Thustmaster Hotas One at black friday sale. I plugged it in, installed the firmware, set all the buttons and axis – everything worked fine. Until I turned off my computer. When I resarted it, the joystick was dead. I had to unplug & plug again – bing – everything worked again. It is like that now all the time: I always have to unplug & replug. Good for my fitness, bad for my nerves 😉

How can I install the device for good?



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Create New...