Jump to content
Sign in to follow this  

Saitek Multi Panel with the MJC-Q400

Recommended Posts

Hello there you guys.

I am kicking and screaming at this point over the Saitek Multi Panel which I recently added to my collection.

I want to use it with the Majestic Q400 Pro, which is always a troublemaker, and it seems the default Saitek bindings are getting in my way.

There is no issue at all assigning functions that the Q400 shares with default FSX inputs. This means that the AP Master, HDG and ALT buttons work fine, as does the rotary button to set the bugs. What doesn't wanna work with me is the special functions. I have the Q400 profile installed into LINDA and the assignments all in place. There is literally nothing else on this machine that would drive the Multi Panel, but still what I percieve to be its default "Plug&Play" button assignments are there. As an example, if I set the Flaps handle to "Do Nothing" (or anything else for that matter), all it will ever do is move the Flaps lever in the Sim. If I grab a default FSX tin can, the Multi Panel buttons work, even though there is literally nothing on my device that I could find that might be driving and assigning them. Either this stuff is buried really really deep or I have become the victim of a curse.

I have cleared all button assignments from FSX via the Standards.xml and have a fresh FSUIPC.ini as well. The device does not even get actively recognized as a controller by FSX (or Windows) so I cannot access any key bindings for it from inside FSX at all.

I have uninstalled the device via the device manager and I have painstakingly made sure there are no traces of any Saitek, SST, Logitech or MadCatz software or registry entries around.

It still seems that the default Saitek assignments are overriding my LINDA, causing only the functions linked with default FSX controls to be available for my Q400.

I am this close to a clean Windows reinstall on this machine and trying this from scratch but since this is already appearing like witchcraft is involved I am wary that this will only yield the same result.

Does anyone have any idea what I could do? Anyone else ran into this issue? Any help would be much, much appreciated. Am I maybe missing something here?

No, Spad.Next ist not an option to me, but for experiment's sake I downloaded the trial to see what that would do and that son of a gun works. With that running, I have no default bindings and all assignments made there will work fine, including special Q400 functions. I very much disagree with that developer's pricing practices though. I get it, it's a nice piece of software, but I need neither a beautiful GUI nor tons of modules and addons for other stuff that I don't use that I would be forced to buy with the complete package which is the only way to get the Q400 module, I do not like to be milked like that. There's gotta be a way to achieve the same thing with LINDA, right? All I need for a starting point is for the panel to be "dead" outside of LINDA.

I tried the "old", free SPAD to supress any commands not set by LINDA, but it doesn't help either. I would be so thankful for any possible fixes for this situation.


EDIT: Did some more fiddling around. The panel is now indeed "dead" without LINDA, but the problem persists, because LINDA apparently insists on sending FSX controls rather than the ones I set up. Had a look at the tracer for the trim wheel. I have it set to "AP VS PITCH UP" which should let one manipulate the AP VS and IAS setting respectively, but this is what gets executed:

[EVNT] Execute Command = "FC:65615:0"
[F] FSX control: 65615   param: 0

Which is, apparently, elevator trim.

What am I doing wrong here?


Edited by lostrealist

Share this post

Link to post
Share on other sites

And one sunday afternoon later, I already found the solution. Maybe someone in the future will benefit if I share it here: Disabling the "Saitek Panels" option on the LINDA Setup page, and I also renamed the associated file in linda-cfg/aircraft/Default FSX for good measure. This disabled all of the default bindings and now my assignments are getting through. It works so well! ❤️

Granted, the button lights on the panel are MEL'd now and the values it reads out have nothing to do with what's set in the Q400 but this I expected. Having all the buttons work any way I want them to is more than enough to ask of LINDA I think, so let me also add a thank you for this wonderful tool and also to Capt. PERO for the many hours of work that must have gone into the Q400 profile. ❤️

Edited by lostrealist

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Create New...