Sign in to follow this  
Guest Milton

Texture alpha channel affects opacity

Recommended Posts

Hi, I encountered this problem when I built a .mdl to replace the default 737 .mdl, but still use default textures. The problem I have encountered is that with a texture that has an alpha channel, which on the default plane affects the reflection (I guess it's reflection, it looks more like specular to me, but I see no mention of that anywhere), but, on my replacement .mdl the alpha affects the opacity of the texture (and thus, the plane)I have found that I can disable some texture related parameters in makemdl, so that the alpha channel is ignored, and I get no reflections or transparency.So, how do I get the alpha channel to affect reflectivity, and not opacity?Thanks,David Rawlins

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

By ensuring that your have "haslightmap" turned on in makemdl and having a _L texture to match each _t texture with alpha.The _L texture can be a simple 256X256 shade of gray for night. The values are added to the day textures to produce the dawn/dusk/night textures.The _L's can be more sophisticated with greater control if you choose by painting the texture templates with various shades of gray.Try RGB 25-75 range.Milton

Share this post


Link to post
Share on other sites

Thanks, but that doesn't seem to be the problem. I don't think I was as clear as I could have been in my original post. On the default 737 .mdl, the textures appear as they should, however, on my replacement .mdl for the 737, the SAME set of textures may result in a semi-transparent plane. On a plane with a lot of bare-metal, this can result in an almost invisible plane.http://home.sprynet.com/~drawlins/_uimages/see_thru.jpgIt seems to me that the problem is in gmax or the export process, but I don't know where.David R.

Share this post


Link to post
Share on other sites

In the makemdl options, you must have 2 options set.hasreflectmap and haslightmapWithout hasreflectmap, the _t texture will be semi-transparent.Without haslightmap, the _t texture will be semi-transparent at dawn/dusk/night with lights on.Milton

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this