Sign in to follow this  
Guest

Damn transparent Canopy!!

Recommended Posts

Hi all,OK, this is my first posting on the Avsim forums so try to be gentle.TO cut a long story short, I have been trying to model the new Bear360 (my first attempt at GMAX) and for cannot get transparency to work on the canopy. I am trying to do it using the material editor (opacity at 35%) but when exported to FS2002 it renders it as a solid material (I even applied the same texture to the body of the aircraft to see if it was problem with my mesh).Anyway, I have attached the GMAX file below if you want to have a look and see if you can give me some pointers, I have already done countless searches on this forum (and the internet) and have followed tutorials but haveing no luck.. Hope someone can help me.The mesh hasn't been tidied up yet, still trying to get the transparent windows to work first..All the best,Captain Trips (Mark Simms)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Where you are going astray is by applying any texture to the canopy at all... Simply use the opacity control in the Material Editor to render the color and transparency. When you apply a texture, it will show up as non-transparent.BillAVSIM OmbudsmanFounder and Director,Creative Recycling of Aircraft Partshttp://catholic-hymns.com/frbill/FS2002/images/fartslogo.jpg

Share this post


Link to post
Share on other sites

Thanks for replying Bill, but maybe you misread the general problem.. I am NOT actually applying a texture, just a colour and adjustment of the opacity control, I am not applying any diffuse map (or not intentional applying one as far as I am aware).Thanks for your time though, I appreiciate the response..Mark

Share this post


Link to post
Share on other sites

>Thanks for replying Bill, but maybe you misread the general>problem.. I am NOT actually applying a texture, just a colour>and adjustment of the opacity control, I am not applying any>diffuse map (or not intentional applying one as far as I am>aware).Mark,I loaded your .gmax file and made a few minor changes:1) Your orientation was 180 degrees off... The a/c would have been flying backwards... :)2) I noticed that you have Preferences set 1 unit = 1 inch. This incorrect. FS expects your model to be System Unit Scale: 1 unit = 1 meter. The only way to export your model to FS with these incorrect settings is to use the "original makemdl.exe" file. The newest one will not work with incorrect units set in Preferences.The correct way is to leave the Preferences System Unit Scale: set 1 unit = 1 meter, and then use "Customize/Unit Setup" to choose what measurment system you want to use while in GMax. You can choose to work in inches, decimal feet, etc. In fact, I frequently switch back and forth depending on what level of detail I'm working with! :) What the Preserences System Unit Scale does is to guarantee that whatever I do will be automaticaly scaled to work in FS2k2 properly.3) I noticed that you had the same material applied to both the canopy and the fuselage. I applied a new material to the fuselage and adjusted the color and opacity of the canopy a bit, as 5% is way too low.4) There were quite a few "co-located vertices" in the canopy, which I fixed by converting it to Editable Mesh, selecting all vertices, and then applying a Weld to join all the vertices within 0.01" of each other. Co-located vertices prevented the .mdl from being compiled.I exported your project to FS2k2 and took this picture to show how the canopy is fully transparent.You are making great progress Mark! I do hope that you are having fun with GMax. It is a steep learning curve, but it's well worth the bother to learn. I've attached the corrected .gmax file for you to this message.BillAVSIM OmbudsmanFounder and Director,Creative Recycling of Aircraft Partshttp://catholic-hymns.com/frbill/FS2002/images/fartslogo.jpghttp://forums.avsim.com/user_files/11014.jpg

Share this post


Link to post
Share on other sites

Thanks Bill, that great. I'll defintely take on board what you say here. Can't wait to get GMAXing again when I get in from work tonight.All the best,Mark

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this