Sign in to follow this  
Guest PAtom

The only thing holding me back is...

Recommended Posts

this error message whenever I try to make an mdl file for the Citation II i am building:Running modelStart! (C:3dsmax5meshesCitation_2.X)Loading X C:3dsmax5meshesCitation_2.X...Processing...Assertion failed: file C:fs8ToolsutilssourceMakeMDLxfileprocess.cpp, line 205 (pMatrix)(Part wing01) Found colocated vertices within triangle ( 3.864249,-24.596542,-0.004557) ( 4.758946,-19.575254,-0.509519) ( 3.864484,-24.596542,-0.004988).(Part wing01) Found colocated vertices within triangle ( 3.847290,-24.596542, 0.036667) ( 4.750559,-19.575254,-0.498536) ( 3.847282,-24.596542, 0.036268).(Part wing01) Found colocated vertices within triangle ( 3.848100,-24.596542, 0.074792) ( 4.750839,-19.575254,-0.488353) ( 3.847857,-24.596542, 0.074519).(Part wing02) Found colocated vertices within triangle ( 4.758946,-19.575254,-0.509519) ( 3.864249,-24.596542,-0.004557) ( 3.864484,-24.596542,-0.004988).(Part wing02) Found colocated vertices within triangle ( 4.750559,-19.575254,-0.498536) ( 3.847290,-24.596542, 0.036667) ( 3.847282,-24.596542, 0.036268).(Part wing02) Found colocated vertices within triangle ( 4.750839,-19.575254,-0.488353) ( 3.848100,-24.596542, 0.074792) ( 3.847857,-24.596542, 0.074519).Model units are 1024.00 units/meterError!Error!Can someone PLEASE explain this!!!!!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

First question is, what version of makemdl.exe are you using? If you are using the one that came with FS2k2, then get the SDK and use the new one. Many of the "colocated vertices" problems disappear by using the newer makemdl.exe...BillAVSIM OmbudsmanFounder and Director,Creative Recycling of Aircraft Partshttp://catholic-hymns.com/frbill/FS2002/images/fartslogo.jpg

Share this post


Link to post
Share on other sites

The problem you are having is quite common. First make a backup.The standard procedure would be to select each of your wings (hide unselected parts) then go to the Point sub-object level. Select all of the points and do a Weld with a range setting of 0.001 in the tolarance setting. Make a mental note of how many points are selected. Incrementing the tolarance (0.002, 0.003 etc.) upward till you have reduced the parts point count by the number of errors for that part. This sometimes only takes one weld. It is not fool proof.Another procedure I have tried is the Optimize modifier This can reduce point AND poly counts and can also distort the part so it is not fool proof either so be careful.As a last resort, you can make a single poly and move the points to the locations listed in the error log. You must be working with your units set to meters for this to work. The new poly will show you where you need to concentrate your efforts then by selecting what appear to be individual points and ignoring back facing points in your wing using a region selection box, watch your point selection count. If you have selected what appears to be a single point but the point count says 2, you probably have the rouge selected. Also remember there is a point numbered 2. Zoom in as close as you can and check from top, front and side views. Then do a Colapse. You may have to make a slight position adjustment to the resulting point. You can also hide points you know are good to narrow the search. Using this method I have even found triangles that were defined with two of the three points being identical which just makes a line, so to speak. In that case, I just delete the offending poly. Go figure!!!Lou

Share this post


Link to post
Share on other sites

Thanks for that tidbit of info! Now, the only thing is, even when I use the newer makemdl and delete the parts that were generating the "colocated vertices errors" supposedly, I get this message:Running modelStart! (C:3dsmax5meshestest_citation01.X)Loading X C:3dsmax5meshestest_citation01.X...Processing...Assertion failed: file C:fs8ToolsutilssourceMakeMDL.sdkxfileprocess.cpp, line 196 (pMatrix)Model units are 1024.00 units/meterSorting by Material...Optimize Parts...Welding...Generate BGL...Error!Error!

Share this post


Link to post
Share on other sites

another trick....create a complete new project in gmax (dont forget to set the animation lenght to 200 frames!!) and simply "merge" your project into the new one. sometimes this cured problems on my antonovs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this