Sign in to follow this  
Guest dasher 7

Need help-opinions on this random issue...

Recommended Posts

I had a successful release of an add-on panel called FlightDeck SFX Panel. The panel is a popular success with over 3000 downloads and only 6 emails back with issues. All were operational error and not a single problem with gauges.So with that I just added several new .bmp's in several colors so simmers could match my panel up closer to their cockpits. Sounds simple enough. But I already saw an issue with my new panels (and already a user who has seen this issue as well), and I would like to get any opinions on it because of what I have been seeing randomly.1. On certain occassions, when I swap out my original brown panel plate (just the .bmp file in the aircraft panel's folder), with a different colored plate, either by deleting the original brown panel or by drag-n-drop overwriting it, when I then select the panel to open it the screen goes blank and crashes FS2004!2. Or after I have made a FDSFX.bmp (name of the file) change on one aircraft and then select another completely different aircraft, where I have not made any changes, it will also cause the same issue.It seems to be random or aircraft (panel) specific. I did not see it happen at all when switching different panels with the default B737-400.My initial thoughts:1. Even though I only changed the panel .bmp - nothing else - FS2004 is seeing this new file as a gauge requiring me to restart FS2004 first or else it might crash?2. The original brown .bmp is one size 655,464 while the one I replace it with is 984,264... different sizes is an issue?3. I created the new panels using PhotoShop 7 and when saving them I was asked to save the "depth" in either 16, 24, 32 bit. I was saving them in 24 while the original might have been in 16. Would this have any effect? I thought one you saved a .bmp it was just a .bmp?4. Could be aircraft-panel specific.Gee, who would have thought I would need to do intense beta testing just because I changed a .bmp file in the aircraft panel folder (not even in the gauges folder).I could really use some insight, ideas or suggestions as I feel I am about to be slammed by emails from simmers.thanks,marcus

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

As I continue to experiement, I think I have found a pattern.When I create a new flgiht, new aircraft all works fine. My panel works great. If I just select a new aircraft and select my panel, the scrren goes black and FS2004 freezes and needs to re-start.However If I stop the flight (exit the current flight), and restart the same flight with the same aircraft that just crashed... it works fine!?!?Something not reloading?-refreshing?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this