Sign in to follow this  
Guest homer310

Why don't party stay where I put them?

Recommended Posts

Hi buddies,I'm almost going mad with the following subject:I'm designing a modell of a Piper Cheyenne IIIb (PA42) for the FS2002 (well, i'm gonna modify it for the FS9 later on...).I finished the airframe and the control-surfaces and exported all into FS2002 and everything worked perfectly.Then I went over and created the gears.As long as they were not animated, everything was ok,but after animating the gear-parts some parts appeared at the wrong position (for example the gear-doors were dislocated from the aircraft and shown about 10 feet from the A/C, or the main gear strut was rotated 90 degrees and appeared on top of the wing).Furthermore some parts had a messed-up shap as if they were pushed or scaled in a diagonal direction.Anyone an idea what to do?By the way: anyone knows how to clone and mirror a part correctly so that the pivot point is independant from the original pivot point?Greets,MichaelPS: Here a pic where you can see the strut on top of the wing and the deformed gear-door...http://forums.avsim.net/user_files/68354.jpg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Michael,I believe you will find your pivot points are out of whack dispite how they "look" in gWax. You will probably have to re-animate some things. Here is what to do:First, make a back-up copy.With the animation slider at 0, unlink all of the offending parts from their parent part and breakdown the children so all are parented to the world.Delete any key frame animations beginning at 200 and working your way back to 0 for these parts.Under the Hierachy tab, Affect Pivot Only, be sure the pivot points position is where it needs to be.Under the Utilities tab, click on the Reset XForm button and then the Reset Selected button.Very Important!!! Go back to the Modify Tab and collapse the stack. This will set the pivot to it's present position and align it to the world and erase any trace of the parts previous history.Relink the part to its parent and re-animate as necessary.Move on down the hierarchy chain re-setting and re-animating as necessary till you get to the end.Lou

Share this post


Link to post
Share on other sites

Thanks,that was a great help as parts are how and where they shell be.But now i got another error:====================================================================Running modelStart! (C:Dokumente und EinstellungenHomerEigene Dateien3dsmaxPA42_NEUfertige Teilepa42.X)Loading X C:Dokumente und EinstellungenHomerEigene Dateien3dsmaxPA42_NEUfertige Teilepa42.X...Processing...ERROR: Scaling null has a translation, ignoring itModel units are 1024.00 units/meterSorting by Material...Optimize Parts...Welding...Generate BGL...ERROR: Animation trigger right_gear_strut_oben not found, mapped to "userdefined8"ERROR: Animation trigger left_gear_strut_oben not found, mapped to "userdefined8"ERROR: Animation trigger nose_gear_drag_link_upper not found, mapped to "userdefined8"ERROR: Animation trigger nose_gear_door_right not found, mapped to "userdefined8"ERROR: Animation trigger nose_gear_door_left not found, mapped to "userdefined8"ERROR: Animation trigger nose_gear_schere_unten not found, mapped to "userdefined8"ERROR: Animation trigger nose_gear_drag_link_lower not found, mapped to "userdefined8"ERROR: Animation trigger nose_gear_schere_oben not found, mapped to "userdefined8"ERROR: Animation trigger right_gear_kolben not found, mapped to "userdefined8"ERROR: Animation trigger right_gear_schere_unten not found, mapped to "userdefined8"ERROR: Animation trigger right_gear_schere_oben not found, mapped to "userdefined8"ERROR: Animation trigger left_gear_kolben not found, mapped to "userdefined8"ERROR: Animation trigger left_gear_schere_unten not found, mapped to "userdefined8"ERROR: Animation trigger left_gear_schere_oben not found, mapped to "userdefined8"Done!Generate crash tree 2 (1200 bytes) Assembling: C:ProgrammeMicrosoft GamesFS2002aircraftpa42_testmodelpa42.azmDone!====================================================================The model is created by makemdl, although not all parts of the gears are animated.Any idea about the animation trigger thing?Thanks,Michael

Share this post


Link to post
Share on other sites

Michael,Rename your parts like so:left_gear_* to l_gear_*nose_gear_* to c_gear_*right_gear_* to r_gear_*Legal names for animations are described in the MakemdlSDK are CRITICAL as they act as triggers to tell MakeMDL to insert the proper code for a particular animation. There is also a script file you can use called TagTool.ms which has all the animation tags and works in either gWax or 3dMax proper (I use it in 4.2). Look for fs_tagtool.zip.Lou

Share this post


Link to post
Share on other sites

Thanks Lou,I was sure that only parts that are directly animated have to be named using the tags. So i thought that parts just linked to animated parts, without been animated themselfes can be named otherwise.But now i know better... ;-)These wer perfect hints. You are great!If you wish a copy of the model when finished, you're very welcome...Thanks,Michaelhttp://forums.avsim.net/user_files/68505.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this