Sign in to follow this  
Guest cwright

Airport 2.6 exclude problem solved ( compiling )

Recommended Posts

Saw a post on the other site where someone was having the exact same problem as me. All you long time users probably already know this so I'am posting it for us newbies. When setting up your directories dont have the Default BGL path and the File BGL path the same or it won't compile an exclude. You will get an error that it cant find the path and you know it exists, its the program that dosen't like it. In the attached screenshot I had my Default BGL and my File BGL pointing to the same directory and it wouldn't compile. Changed my File BGL to the root of my location and all is well. Dont understand it but it works. If you dont have an exclude it works fine.Muskoka

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Glad you solved it!Can't wait for the Windemere scenery.Weird haw the lake district only has one lake! Bassenthwaite!

Share this post


Link to post
Share on other sites

Don't believe this is a problem at all as I usually re-set my directory pathes for each new scenery area and designate the two parameters you quote as the same folder.....and exclude goes where I tell it (them) to go.I have a feeling that part of your problem lies with the "name" of your scenery (*.apt) file. Older versions of Apt design program had a hard time, if not non-functional, when that name exceeded 8 characters, not counting the file extension. Out of habit, I still keep my names to 8 or less. And for exclude files especially, I keep the name to fewer than 8 to allow for the characters that Apt itself assigns to an exclude file.This is why I make exclude files as separate *.bgl from the actual scenery *.bgl; in other words, a separate exclude *.bgl for each instance one is required, plus additional *.bgl's as necessary for the scenery itself, and each named accordingly.

Share this post


Link to post
Share on other sites

Hi Garvin. I also re-set my paths for each new scenery as well. I tested what you said out of curiosity of course and it dosen't work that way for me. Created a totally new scenery directory ( e:FS2002sceneryWindScenery, Default and File BGL paths going to the same, compiled with no exclusions and everything was ok, file name when saved "a.apt". Added an exclusion, changed nothing in the directory structure and it says "problem installing the exclude bgl file to path blah blah blaha_EX1.bgl to FS. If I change the File bgl path it works ok. Oh and I'am using Build 149. It really dosen't matter to me how it works as long as it works. The only reason I posted this was I saw OTHER people having the SAME problem and thought this might help. Whatever works, us it. I'am using XP Pro if that has anything to do with things.Muskoka

Share this post


Link to post
Share on other sites

I don't know how you figured that one out but I sure am glad that you did. I spent many frustrating hours on this, and your solution worked the first time. In my default settings the whole line for the exclude file was blank.My scenery is kept under My Documents, and the scenery name is more than 8 characters long. I have build 148.From all the other posts on this topic, I am sure there will be others thanking you.John Woodward

Share this post


Link to post
Share on other sites

>From all the other posts on this topic, I am sure there will >be others thanking you. I am one! I originally had some autogen trees growing up through my taxiways, so I used the standard exclude square, which worked fine. Then recently I noticed those trees had grown back! When I saw Muskoka's original post I immediately checked and, yes, I had recently changed the settings and the two entries were the same. I changed it as per Muskoka's post and the trees vanished. So many thanks, Muskoka. Oh, yes, I do use long file names - as far as I'm concerned eight character file names are a part of ancient history! Just shows how useful these forums can be. Best regards, Chris

Share this post


Link to post
Share on other sites

I don't mean to flog a dead horse here, but did you add the exclude instruction to the original scenery *.apt? In my explanation above, I distinctly mentioned creating a separate *.bgl for each exclusion command.As for the 8 character issue being 'ancient history', I stated that it was from habit...of course it is old news and I believe had to do with the DOS function of the older versions of Scasm; not the Apt program per se.I will try some more tests of this problem.....I always find it interesting why each of us using the same program can get different results!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this