Sign in to follow this  
Guest Claviateur

gmax building has dark textures until up close

Recommended Posts

I just made my first gmax building for use in scenery. I successfully compiled and placed it in my scenery. Everything seemingly worked well until I saw it in FS2002. Apparently the textures DO load, but they are not shaded until you get up close. So if I'm 500 meters away, it looks totally black. As I get closer, the textures are lighted towards my perspective so that as I get to within 20 feet of the building, the textures are almost fully lit. Any idea what could be causing this?Thanks for the continued help,Enrique

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

In imagetool you need to make mipmaps for your bitmap.Cheers, Christian

Share this post


Link to post
Share on other sites

Hi Enrique,I think this problem is related to the BMP format. Did you by any chance make it DXT1 or DXT3 without having an Alpha Channel in it? I suggest you convert it in Imagetool to 8 or 16 bits unless you wantit to be transparent or reflecitve. I might be mistaken but I remember having this problem once and it was related to the image formatCheersMichel

Share this post


Link to post
Share on other sites

Thanks for the replies. The problem was the lack of mip maps. I created Mip Maps with ImageTool and saved it as a DXT1 and viola, it worked perfectly.Thanks againEnrique

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this