Sign in to follow this  
Guest

Coast Line Maker Weirdness...

Recommended Posts

Hey guys,I've been tinkering with Coast Line Maker and have to say that by far it is the best thing out there. However, I'm coming across something that is making me pull my hair out by the fistfull. I followed Iain's tutorial to the letter, but here's what I come out with...http://www.pacificnwdigital.com/jpegs/FS.jpgHere is a shot of the project in Coast Line Maker. I've excluded the coastlines that are appearing, as you can see in the dialog box...http://www.pacificnwdigital.com/jpegs/CL.jpgAny ideas???JimBTW, I'm using version 1.1.2

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi JimCheck if the VTPLayer "replace flag" is set to a value of 1 like this:VTPLayer 8, 1That should replace the default shoreline with yours.Hope it works for yaKen

Share this post


Link to post
Share on other sites

Hi Ken, thanks for the quick response!I checked the VTPlayer flag setting and all are set to a value of 1 VTPDataArea 1, 0, 3, 22 VTPLayer 8, 1 VTPNumTexturesInLayer 0, 0 VTPDataArea 1, 0, 3, 23 VTPLayer 8, 1 VTPNumTexturesInLayer 0, 0 VTPDataArea 1, 1, 0, 0 VTPLayer 8, 1 VTPNumTexturesInLayer 1, 0 Any other ideas?Jim

Share this post


Link to post
Share on other sites

Hi Jim!It is quite possible that the coastline there is on another layer so VTPLayer 8,1 does not work. But!Try also this:

;VTPDataArea 1, 1, 0, 0 VTPLayer 8, 1 <<==== Put here 1  VTPNumTexturesInLayer 1, 0	   VTPTextureId 4, 0   VTPPolyCount 1, 0;  VTPPolyMethod2 09, 1, 0;VTPWidePoint  ....

This is also a solution. If You draw a line on layer 8 then because of VTPLayer 8, 1 all the lines on layer 8 will be excluded in LOD13 quadrants which Your line crossesRhumba also made a nice *.inc file which has very useful instruction in it, I think it is VTPAreaExclude , , Unfortunatelly I think this inc file is missing in TDFMacros.zipAnyway, if it does not work on layer 8, try also other layers, from 4 to 32.Hope it will help You. Best regards,Goran BrumenFS Slovenija 2002 teamhttp://slovenia.avsim.net

Share this post


Link to post
Share on other sites

Hi Jim,Sorry this reply is late, I've not looked at AVSIM for a few days ...The cause of what you see is probably that you have the new BGLs in the main scenery folder, rather than in a subfolder.This means that the old and new coasts have the same "importance", but if you put the new stuff in a subfolder and put it higher on the list in Scenery Library, it will kill off the old coast.Several CLM users have had this problem, and I've added more detail on this into the documentation for Version 2.0, which should be out soon!Cheers,Iain.

Share this post


Link to post
Share on other sites

Bwah-ha-ha, cool! Glad it was something so easy!Thanks for the heads up and the program Iain!Jim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this