Sign in to follow this  
Guest Robi

EDO tree question

Recommended Posts

How do I add a texture on Tree on my own macro with EOD ?I've try to do it but after compiled, trees appear flat on every side.. they are the same as what i see on 3d prev in eod.Since now for me isn't possible take an image from fs, I've attacched a little pic taken from EOD to figure you what i mean. Imagine the pic as taken from fs with textures...Hope you understand what i mean.Apologyze for my bad english...Thanks all Ciao Robi

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create a simple wall. Make up a texture with the tree surrounded by eg a black background. Create an alpha channel corresponding to the black background. Use DXTBmp to convert the texture to 16 bit 555-1. Apply the texture to your wall object in EOD and select options 'no shading' and 'turn to always face pilot'.You will have simply great trees especially if you create seasonal textures for each one. I know our good friend Gerrish has created his brilliant tree libraries - but I couldn't understand a word about loading the trees SDK and all that stuff and the need for users to load several libraries and all. I now have a range of conifers and leaf trees that I just drop wherever I want in sceneries - dead easy

Share this post


Link to post
Share on other sites

BTWI forgot to add.Don't create your trees with a fixed scale. If you use the variable scale option you can easily vary the sizes of your trees in your scenery - looks much better.Also, the choice of image type is important. Look back at the recent threads on the forum where I had problems with 'non transparency' of my tree backgrounds that were solved by using 555 bmps.

Share this post


Link to post
Share on other sites

Thanks RollerBall i'm going to apply your suggest..Also , i don't know how but i've apply a Nova tree texture on my trees and it's appear right.. howewer i'll try to create a simple wallmaybe it's betterThanks

Share this post


Link to post
Share on other sites

Hi Robi!If You have made Your own texture, then it is probably in wrong format. Try loading it into imagetool and then convert it to DXT1 or 8 bit with transparency (which I do not advise!). Do not try using DXT3 because You'll get problems with object behind the tree - they won't appear correctly!Best regards,Goran BrumenFS Slovenija 2002 teamhttp://slovenia.avsim.net

Share this post


Link to post
Share on other sites

Hi GoranThe texture that i'used thr first time was not my own.Howewer now is right with a Nova texture that's good for my macro tanksCiao, Robi

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this