Sign in to follow this  
Guest

DirectX8 Driver Error w/ High Detail Textures

Recommended Posts

Greetings All. I've been away from FlyII for a few months and decided to revisit it. Anyway, I recently upgraded my old GeForce2 GTS 32MB video card for an ASUS GeForce3 Ti200 card. I'm running Nvidia's current 28.32 Windows 98 drivers on the Ti200. My problem: Whenever I select High Detail Textures on the graphics options screen, FLYII chugs for a few seconds on loading and I get the following error dialog: "DirectX8 3D Driver Error - DrawIndexedPrimitive SVertex failed". Has anyone encountered this before? Could this be an NVidia driver issue? I've never used High Detail Textures before, so maybe I have a configuration problem. Turning it off eliminates the error. Here's my render.ini:[Graphics]mipLevelCount=8vertexIndexFormat=0premultiplyColorAndAlpha=0allowAutoMipMapping=1directTextureFlag=0[Textures]maxTextures32=1maxTextures64=16maxTextures64_565=16maxTextures128=82maxTextures128_565=999maxTextures256=40maxTextures256_565=42maxTextures512=8maxTextures512_565=0maxTextures1024=1mipMapFlag=896[NonAGP]maxTextures256_565=0[AGP]maxTextures256_565=0Any help is greatly appreciated, and thanks!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thanks Ken, for the suggestion about changing the 999. BTW, the Ti200 card is a 64 Meg card. Nothing I've tweaked in the render.ini has had an effect so far. May try switching to a different release of the video driver.Rich

Share this post


Link to post
Share on other sites

As far as I remember I solved that problem by increasing the AGP aperture size in the BIOS. You can try increasing or decreasing that and see if it works.Take careMike

Share this post


Link to post
Share on other sites

I also was able to solve the problem by increasing the AGP Aperature size in BIOS.In my case, (Geforce 2 GTS 32MB, 512 MB Ram, & High Detail Texture, DX8 T&L) I had to increase the AGP Aperature size to 128MB. Settings of 16, 32 and 64 MB all gave me a "...svertexfailed" error just after the load screen finished.Note also because of the 32MB video card memory, I do experience occasional lock-ups requiring a re-boot (My fault - pushing the 32MB card too much). Hope to resolve this with a new Geforce 4 TI4400.Fly!II v230 with all the great add-ons is a fantastic flight sim.Thanks to all the talented and generous developers out there.Richdude

Share this post


Link to post
Share on other sites

Rich,I got same error and decided to use old Nvidia drivers (12.83). Now Fly! II is working without problems with T&L selected. There is another way to change the FLY.INI to avoid this error, but i

Share this post


Link to post
Share on other sites

Thanks all. Selecting DirectX8 instead of DirectX8 T&L did sidestep the problem. Now that I have a 64MB card, I can't believe I've lived without the high detail textures for so long. Still tweaking things a bit here, but I'm now getting framerates in the mid-thirties in the coastal areas I fly in. Rich WilliamsPIII 933@980GeForce3 Ti200 64MB 28.32Patched to 230

Share this post


Link to post
Share on other sites

Like I mentioned several months ago (old forum): if you want to use high detail textures and DX8.1 T&L together (and with the latest Nvidia drivers) : 1. set aperture size in bios to half the amount of installed system ram and 2. do never over-allocate texture memory slots in your render.ini. Also do not use the 999 setting. So, if you have a 64 Mb video card, never allocate more than 64 Mb texture memory (use mem calculator). I have a Gforce2 Ti 64 Mb and it works just fine using DX8.1 T & L.Regards.Ludovic P.

Share this post


Link to post
Share on other sites

On a related topic, when I moved my FLY-II environment from a 400 MHz Pentium-II Dell to a 1.4GHz AMD XP processor, but keeping the same video card, a 32MB ATI RADEON (with PCI interface), both on Windows 2000, now I get a "blink" about every 10 seconds when running Fly. The entire screen flashes, I think to black, for a small fraction of a second.Any ideas as to what causes this?--Paul Dickson

Share this post


Link to post
Share on other sites

I think it may have to do with drivers or something... ATI always had lots of trouble developping correct drivers for their cards... The Radeons (especially the new ones) have great potential... but the drivers were unstable (I think the problem is solved for the new boards but not the old ones...)CheersTomI'm not certain about what I said so if something is wrong please correct me...

Share this post


Link to post
Share on other sites

Would these BIOS settings also apply to a 32MB ATI RADEON with PCI interface rather than AGP? When I moved from a Dell Pentium-II system to a custom AMD XP1400 cpu on a VIA motherboard, keeping the same video card, the screen now "blinks" about every 10 seconds when running Fly-II.--Paul Dickson

Share this post


Link to post
Share on other sites

(Sorry for double post. The way this conference software works you have to refresh the page to see your post, even if you come back much later. So I thought the first one didn't "take".)My old computer didn't have an AGP slot, which is why I got the plain RADEON. Would the RADEON 7000 be considered one of the new breed that works?--Paul Dickson

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this