Sign in to follow this  
Guest Lobaeux4

Strange separating throttle problem....

Recommended Posts

I was flying my PIC to JFK when I noticed that suddenly only the left throttle/engine was being controlled by the AT (no failures set or active). I disconnected and found my joystick would also only move one throttle lever. Then I pressed E+2 to see if the other would start to work, and both stopped working! I crashed in the water about 10 miles off Rwy31L.Anyone know what key I may have accidentally pressed to cause this sudden separation of the left and right throttles and what, if any, keypress could sync them back up again?thanks...michael

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I've had this happen a couple of times with my Suncom Throttle. Not specifically related to the PIC, it's happened with other planes as well. Usually it's the left throttle that works and the right just stays put (but can be moved with the mouse). I usually just treat it as an emergency, a stuck throttle, and land. Then I have to restart the simulator to get both throttles to work again.JoeBTW, in the -130, you get a stuck throttle, you shut the engine down, no big deal. In FS2K2, you shut an engine down, it's a very big deal, and most planes, especially props, are nearly uncontrollable. For FS2K2 I really hope they work on making emergency or abnormal situations better.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this