Sign in to follow this  
Guest

unable to land

Recommended Posts

Hi,I'm just wondering if somebody experienced the same.Trying to land at some airports is almost impossible for me. On the final (flaps conf.+right speed+gear down+about 100 feet above the runway), suddenly the plain lifts up (up to 2000fpm) with attitude -45 degr. (nose down) and won't let me descent. Unless, I retract flaps to half, shut off the throttle and experience a free fall on the runway. If the ranway is long enough I do manage to land (I'm lucky not having any sick passengers physically behind me).I noticed this behaviour at some airports created with FSImport, but can't name them now, as I always thought it's my lack of pilot skills (have been flying real plains for only 3 years).I imported a FS2k2 scenery last night, where there is no db entry for airport and runway (basically landing in the middle of a crop-field) surrounded by imported 3D models. I can't land here at all, although tried various plains. It simply won't let be bellow 100feet AGL. Every attempt to descend I end up in negative attitude even with engine shut off. BTW, tried speed up descend by full rudder one side and full airleons to opposite side. Bad luck. Any idea what to check or what it might be?Thanks,Rene

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this