Jump to content

Sign in to follow this  
Guest

HELP!!

Recommended Posts

Guest

I really need help here....Sorry for the subtlety here, but I have majorissues regarding brakes. For some reason, the right pedal is activatingthe LEFT brake (and yes, I've checked my settings).I 've deleted the keys in the key set-up for "Airplane"and I get the same thing. Maybe I need to change itin control.txt somewhere, but I'm not familiar enoughwith that text file to know what to do.Any advice. guys?JimPowerMac G4-933/60 GB/768 MB/Mac OS 10.2.4; 9.2.2/GeForce 4 Ti/Ch Fighterstick, Pro Throttle, Pro Pedals

Share this post


Link to post
Share on other sites
Guest

I just enabled my gameport Pro Pedals brakes myself, so I'm a new control.txt expert!Without actually trying, I'd say there's 2 ways to fix the problem.1) In Fly, go to setup axes and define the brakes there, about the same way you define buttons.or 2) look in control.txt toward the end for Aircraft Axis 4 and 5 (at least it's those on my setup) and see if those code blocks make sense as referencing your brake hardware. (There's a title line for whatever hardware is controlling each axis.) Where it says Element: X axis in the block you've decided is the brake control, change that to Y and vice versa for the other block.I haven't actually tried this myself, but that's how I'd attempt it! My problem was centering my rudder pedals. My gameport Pro Pedals were feeding in a left rudder value, even after all kinds of calibration. Finally I realized I could edit control.txt and decrease the "maximum" and "center" values of the rudder axis code, which makes Fly think the rudder is centered now that the distance between center and maximum is reduced.Hope it works for ya!Eric

Share this post


Link to post
Share on other sites
Guest Roderick

Hi Eric. I'm new to simming. Your fix on rudder center may be what I need. On approach to landing I'm all over the runway (and beyond). Rudder action seems super sensitive. What max value did you use for rudder? Any other suggestion? Thanks, Roderick

Share this post


Link to post
Share on other sites
Guest

Sorry for the delay!If you're all over the runway, sounds like you need to adjust the null zone on the pedals. Or maybe first check the exponential sensitivities in Airplane...Options when you're running the sim.In Fly, control.txt gives you some control over your controls, and it's not too hard to work with. First thing to do is run Fly, do Test Controls (under Options) and see if the sliders there are all centered when they should be. My rudder problem showed the rudder slider left of center, compared to the pitch and roll axes sliders. When I levelled in flight, aircraft rolled to the left."Test Controls" lets you save a report of the exact values of inputs. Do that, and alt-tab back to Windows. Look for Fly Control Diagnostics.txt in the Fly directory and you'll see whether the current value for your controls is centered (like 32767) or not.Since I needed Fly to think my rudder pedal input was more to the right all the time, I went into control.txt and decreased the maximum control value from the default 65535 to 52000 or so. Fly thinks everything is fine now. The difference in your Diagnostics actual center value and 32767 is how far you need to decrease the max (to correct to the right) or add to the min (to correct to the left). Adjust the normal center value about the same I guess.It'll make sense after you play with it for a couple hours. HA HA!Let me know if it's working...

Share this post


Link to post
Share on other sites
Guest

Forgot to say that the rudder sensitivity, if it's not fixable through the Airplane...Options...Exponential settings in the sim, may be cureable by increasing the Rz-axis null zone value in control.txt...not that I've tried it!

Share this post


Link to post
Share on other sites
Guest

Well I guess I wasn't too helpful so far, was I! Here's some new info...since I have actually played with the settings more now.In control.txt, increasing the null zone value will let you move a control more from center before it takes effect. Unfortunately, when input is then accepted, it's at whatever absolute value the control gives then. Thus, setting a large null value on the rudder lets you move your foot a long way (as you might in a real Piper Warrior, for example) but suddenly instead of gradual effectiveness, you have full-over rudder (with a somewhat high nullzone value). Boom, you're yawing and rolling, no good for runway control or fine maneuvers.So that's not promising. I guess increasing the min and max values won't help this problem either. Don't know what to do.From what I can see, control.txt allows you to tune out problems in your gameport device potentiometers. If your throttle pot is sticky at the bottom and won't let you have zero (which you could see in Windows' game controller properties test), you can change the min value in control.txt to whatever min/max values your pots will give you. And so on. That seems to be the main use.You can also adjust Fly's understanding of where your devices center values are, by widening or narrowing the min-to-max range in control.txt and resetting the centerpoint value there too.And it seems you can map device axes to Fly axes, if Fly goes crazy and reverses footbrakes, yoke axes, etc.As Forrest Gump says, that's all I have to say about that.If anyone knows how to adjust Fly so that takeoff power and attitude in the 172 and Warrior force you to use realistic "right foot" let me know! After an hour of touch-and-goes, I expect to have a charley horse...

Share this post


Link to post
Share on other sites
Guest

I may have found a cure for the too-sensitive rudder problem, as well as my need to stomp on the thing for greater Piper realism. I'll let you know later today...if it works!

Share this post


Link to post
Share on other sites
Guest

I figured out the rudder sensitivity problem. It's not in control.txt at all. That's only where you can tune out gross joystick problems like pot limits and scratchy null zones. If your stick/pedals are good quality and clean, you shouldn't have to mess with control.txt at all.Where the magic goes is in aircraft files that are inside the PODs. You can modify values by unpodding the right files, editing them, and saving them in the existing Fly directories that the POD says they fit.Look for the the .MIX suffix file, unpod, and open in Wordpad or some editor. Find the RUDDER section (for example) in the upper part of the file and notice two values in it (this isn't a complex file). If you want less sensitive rudder action and more "stomp on it!" action, decrease these values. Same for the other axes.As my old instructor used to say (Dave Hiltz, a master)...boot it!For more torque effect (I found my Flyhawk's torque wasn't even activated, even though I set the sim to "full real" settings), look for the torque factor value in the .PRP file of propellor planes. Increase it and enjoy "right foot!" in the climbs.All aircraft performance is contained in these text files. Figure them out, and you can do a lot. Unfortunately, the technical stuff is REALLY technical -you'll be lucky to make some general adjustments.Write here if it works out for you!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...