Sign in to follow this  
Guest tonyc

Autogen test # 8

Recommended Posts

Hi all,I finally completed the data template file and I think it has enough flexibility now to place the models in a large range of possibilities : from fixed models position x,y allowed in a single texture grid to a repeated randomized position.We can now have grids with all the objects carefully placed according to roads and buildings or houses images and have generic and randomized grids coverage where position doesn't really matter.All the tests done until now are with textures higher than 64x64 : with this slots used, the rendering will be even greater...I didn't checked out yet the water pb that Tony reported ... I'll try now during other tests.Cheers,Laurent (rotw)110404_AVSIM_AUTOGEN_TEST_V10.zipin http://rotw.simvol.org/beta/ don't miss the '/' after betahttp://forums.avsim.net/user_files/96402.gif

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Laurent, I've confirmed the objects in the water when teleporting from KSFO to Cleveland, Ohio. From the pic , you can see the effects. currently, Steve's models, Superquick and NYD models reside in shared scenery folder.tony

Share this post


Link to post
Share on other sites

Hi Tony,Ok, let me fix that with the next test version ... anyway the model number per grid has now decreased and the fps are good enough to complicate somehow the water algorithm ...Cheers,Laurent

Share this post


Link to post
Share on other sites

Hi all,Cleveland shallow waters have been drained !I added a 9_WATER_FIX_1 folder in http://rotw.simvol.org/beta/ don't miss the '/' after betawith the fixed dll.I made a complete round of the area and, except for one spot were ground is saw-like, all seems good to me.BTW I discovered that the SDK GroundType API doesn't return GROUND_WATER over water but GROUND_WOOD ! As soon as I modified the controls routine with this, many things were fixed ... but not all ... because we have also GROUND_TURF or GROUND_CONCRETE in the water ! And those grounds type are very used in the land areas ! Cheers,Laurent

Share this post


Link to post
Share on other sites

Laurent, things look very very good. No models in the water and many scttered objects to fill the landscape. The buildings flicker. Their faces have the texture that moves left and right, creating a flicker.Is it my mipmap settings or something else? I am just curious to know if you experience the same.tony

Share this post


Link to post
Share on other sites

Hi Steve, Tony and all,Great to hear you Steve ... I also have some flickering but only with Steve's striped white and blue buildings and the movement is up and down ... others are normal.I think this is due to my 3D card settings and we all know that striped patterns are the video rendering enemies.Cheers,laurent (rotw)

Share this post


Link to post
Share on other sites

that's correct, Laurent. Only the white and black building flicker. Steve, can you comment on this phenomen?tony

Share this post


Link to post
Share on other sites

Guys,I think it's the "moire" (spelling?) effect caused by the stripes. Maybe if we use more "like" colors (tan and brown, or gray and black, etc.) this will be less noticeable. Maybe we can use other patterns instead of stripes.I recall this being a problem but not just with Fly!, I think ProPilot had a similar problem and possibly MSFS...Just my 2 cents...http://www.avsim.com/hangar/fly/dfdg/banneraa.jpg

Share this post


Link to post
Share on other sites

I have seen this problem on my friends computer but not my old one. :-) So I wasnt aware of it until then.But as Alex says, the best thing would be to use those textures more friendly to all types of video cards. Remember though, the building textures you are using at the moment really had been made before I started making for Autogen.The buildings coming are more like the ones you see in FS9 and the like so I hope these problems will be minimal. And they will be made in 64X64 texture format, so a little fuzzy too. So dont worry too much about the models now, look forward to whats to come.All the very best to you all, Steve.My Websitehttp://www.wrexhamspace.orghttp://www.wrexhamspace.org/Steves%20Card.jpg

Share this post


Link to post
Share on other sites

this is nice to know. I will play with the mipmapping to see if there's a connection.tony

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this