Sign in to follow this  
Guest

Running Fly II on a Titanium G4/800 and MacOS X 10.1.5.

Recommended Posts

I have one of the new Titanium 800 MHz PowerBooks with the 1280x854 displays and 32 MB of video RAM. Anyway really great machines but...I installed Fly II (Build 216 out of the box it looks like from the Settings Screen splash at the bottom of the pop up) under MacOS X 10.1.5. It starts up running full screen and I can't get the menu bar to display, at all. According to the PDF using the bar is supposed to bring up the menu bar if hidden. No dice. All I can do is blunder around trying various key strokes which isn't much fun.Has anyone successfully run Fly II on a Titanium under OS X? If so did you do anything special? I tried the HID update but I'm not even trying to use a joystick yet.This is pretty frustrating and at the moment Fly II went into the Trash. I'm a bit of a Mac newbie but I still managed to get a rather pesky Windows application to run under Virtual PC so I'm no dummy either.Any help will be appreciated.Thanks,Stephen

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Stephen,Wow! That's the reverse of what Mac users usually get with II. Usually, we can't get rid of the menu bar!Try this: open the fly.ini file in the Fly system folder (save a back-up first -- just in case) and look for the section starting with "UI" in brackets. At the bottom of the section, add this line:allowHiddenMenubar=1This is what most of us have to add to be able to toggle the menus with the space bar. If the bar doesn't toggle with this setting, quit Fly and change the 1 to 0 in your new entry. Then restart Fly and see what shows up.You can also try running Fly in a window to see if the bar appears. Type command-return[/] to toggle between full-screen and windowed mode while in the program. For this to work, you'll probably have to insure that Fly's screen size is one click less than your desktop (ex: d-top at 1024x768; Fly at 800x600)Also try booting in 9 and see if the probelm is still there. This may ultimately be the best short-term approach, as Fly has some other problems with OSX that Richard Harvey at TRI is currently working to correct. Rates will probably be better in OS9 until the patch releases.I don't have OSX so this is a shot in the dark. Let us know if it works.Regards,

Share this post


Link to post
Share on other sites

I had this exact problem with my cube in 10.1.5. try COMMAND+Return. should work like a charm. That switches from OpenGL full screen, to windowed mode. Which allows you to access the menu bar.

Share this post


Link to post
Share on other sites

Sorry for not posting the results sooner but the "Command + Return" solution worked like a charm. I then edited the "fly.ini" file to set something like "AutoFullScreen" or similar to 0 (False) instead of 1 (True). Now it starts in a window and stays in a window.Thanks

Share this post


Link to post
Share on other sites

I have a feeling this is an 10.1.5 issue. Because it happened for us both in that OS. I believe Command+Return is the default command to switch between Full and Windowed mode (It's the same in VPC, thats how I figured it out).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this