Sign in to follow this  
Guest

Fly!2k performance

Recommended Posts

I just upgraded my G3 233Mhz with a Sonnet G4 500, plus maxed the RAM to 385 MB and added a Radeon card.So, I notice marked improvement over my earlier system (with a Voodoo Game Wizard). I'd like to know, however, whether this (see below) is as good as it gets with my new setup:With minimal graphics settings, instruments scrolled down: 36 fps, with panel (sacred six visible) 14 fps.At SFO taxying, max settings: 7 fps, panel down: 11 fpsBay area scenery max settings: 12 fps with panel.EDDL Rhein-Ruhr scenery taxying: 8 fps, with panel down: 17 fps; flying in that scenery: 12 fps, panel down: 30 fpsThe scenery appears "polygonny" beyond about 5 miles out when on max visibility (20 miles). No problem with visibility = 10 miles.What do you think? Anybody out there with a similar setup?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Jorg,I upgraded my 63/300MT with a Sonnet G3/500 in August and noticed similar rates to what you're seeing with 2K. Almost no improvement with panel fully showing but much better everywhere else. 2K predates AltiVec technology so there should be no difference between G3 and G4 performance.What OS are you using for these rate tests?Have you found the "unofficial" Radeon patch for 2K in the AVSIM library? It has a new .vcf file for Radeons (they came out after 2K and weren't supported in the original Fly1/2k release). If you don't have this, please try it. It might help those polygon issues you mention.As an aside. adding the G3/500 had little effect on Fly II rates for me.Regards,

Share this post


Link to post
Share on other sites

Allan,thanks for your reply. I am currently running OS 9.2.2; contemplating to get 10.2. - hoping for better results because of the improved OpenGL.I do use the Radeon patch. I'll have to do some more testing to get to the bottom of this polygon trouble.

Share this post


Link to post
Share on other sites

Thanks, Jorg,I doubt 2K will run under 10-- should go straight to classic. Fly II runs best on Jag when you boot into 9--maybe the Jag installer is adding something to the 9 partition that helps.Here's something to try. In the AVSIM library is a little file called Fly Tweaker or something like that. Search by "tweaker" and I think you'll find it. It has a little spreadsheet that helps you calculate texture slot allocation relative to VRAM, and a nice explanatio of what different slots handle. Make a copy of the Radeon .vcf file and play with the copy. Do the same with render.ini and see if it helps. In experimenting with settings, you may find something that works better than the defaults.CAN you post a picture of the polygon effect? Control-tab takes a screenshot. You'll need to take the shot into a photoeditting program to make it a jpeg small enought to post.

Share this post


Link to post
Share on other sites

Thanks Allan,I'll go and find "Fly Tweaker". See enclosed screenshot (Fly! scenery Chicago, visibility set to 20 miles) - what do you think? The "polygonnality" is, of course, more noticeable when moving. Maybe I have no reason to complain?Let me know...Regarding OS 10.2: I'll get that sometime around X-mas, later on a copy of Fly! II. Then we shall see.Thanks for helping!Jorg

Share this post


Link to post
Share on other sites

Jorg,I take it you're referring to the greenish strip by the river? If not, post another version of the shot with the offending area(s) marked. I've not seen that in 2K.We saw something similar in beta testing II, but it was gray. Indicated too much memory allocated to Fly, not leaving enough for the system to run OpenGL. I started testing with 256MB physical. FlyII needed 208 min. The "normal" system before invoking the heavy graphics routines needed 40. That didn't leave much working room, and VM really messed with rates. Some tiles couldn't load needed textures, so were gray. However, 2K doesn't do OpenGL as I recall.Before tweaking the ini files, try changing the allocation to Fly (if you've set it high) to something that leaves about 100MB free RAM for the OS. Turn off virtual memory if it's on.Are you in 16- or 32-bit color? Try changing it. Also try setting your desktop resolution and color depth to the same as you set for Fly. Example: if Fly is set to run 1024x768 in 32-bit color, set your desktop to 1024x768 and color depth to "millions of colors."And keep us posted!Anyone else ready to jump in here??

Share this post


Link to post
Share on other sites

Allan,thanks for your support. Actually, it's NOT that green stripe - I am referring to the "choppyness" in the distance, about the upper third of the scenery.I'll post another screenshot when I have time - I am rather busy until Friday.I'll also try to give Fly! less memory. Right now I am giving it 300 out of 384 MB.See you later!Jorg

Share this post


Link to post
Share on other sites

Jorg,The effect isn't too drastic from what I can see in the shot. Maybe I need to see the original picture file--can you e-mail it when time permits? I have broadband so a large file isn't a real problem.Right now, I'd say that you're seeing normal performance.When I first bought Fly! v1.00000.... it was pretty bad. I had only the on-board 64-bit Rage Pro chipset with 6MB VRAM. The original Fly! produced a distinct vertical gray wall (segmented) at the set limit of visibility. UGLY! If I went to external view and positioned the camera above the a/c, it looked like I was flying in the center of a giant toilet paper tube.A later patch and tweaking the video choices applied diffusion to the wall so it was less obvious. Adding the Rage Orion card helped even more. I think that is how the view limit is handled. There's a real wall at distiance X that gets a blur applied via help from the video card to give the effect of the view fading out due to distant haze.Try setting the max view in the Environment screen 2-5 miles lower than the max view set in the Graphics screen. I tried today over LAX scenery and it seemed to help the limit of view be a little more diffuse that when I ran 20/20 (I usually set the Graphics screen to 20 miles and the Environment screen to 15. Twenty miles is the max allowable for 2K so maybe you are seeing the effects of the wall segments when running maxed out.

Share this post


Link to post
Share on other sites

Allan,thanks for your reply. I suppose, the "polygon"-effect is not all that noticeable on still shots; it is more of a bother when moving. Of course, none of this is a serious problem with flying, and - as I mentioned - I used max. visibility etc. for the screenshots. To improve framerates I mostly operate with visibility under 10 miles anyway, and then the picture is almost perfect. I can live quite well with framerates around 10 - 12 fps.Now, what about Fly!2k and OpenGL? Doesn't Fly!2k also use OpenGL for rendering the panels?I was hoping to have some more improvements waiting for me when I'll upgrade to 10.2. Of couse, being able to run Fly! II would be nice, but I'd still spend a lot of time in aerosoft's Rhein-Ruhr scenery.Can you educate me on that issue?Thank you!Jorg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this