Sign in to follow this  
Guest

Slider & Throttle control issue with Logitec Wingman jo

Recommended Posts

Hello,I've been lurking for a year but now it is with great pride that I post here for the first time!Before the 240 patch, I used to be able to correct the throttle span of my Wingman joystick slider from an irritating 25%-75% of Throttle to 0-100% by tweaking values in the Control.txt file in the Fly folder. This was not perfect as Fly!II regularly stomped my values but it did the job.Now with the new patch, the values I enter in Control.txt are just ignored. Has any of you figured out how to fix once for all this slider issue? Is it only occuring with the Wingman joystick?Thanks a lot for any help!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Can you post the details of your system, including OS, machine specs, and video card info (see my signature for an example)? That will help people diagnose the problem better.I apologize for not responding sooner--I've not been home in the evenings this week and am behind on my reading!

Share this post


Link to post
Share on other sites

Hello Allan, and thank you for your answer!I fly on a plain TiBook @ 800MHz, 512MB RAM and the default RageM7 video card (32MB).I used to have to boot in OS9 to be able to use Fly!2, but now with MacOSX 10.2.3 & the 240 patch, it is running great!I have always had an annoying problem with the slider of my joystick, a Wingman Extreme Logitec. I have 2 of these so I could prove the problem is not coming from the joysticks itself. I also recall someone posting a trick to fix the same problem, but on Windows.Basically the slider control's range is only 25% to 75% of the throttle for all planes.The way I used to correct this was to change the following lines in Control.txt:*** Begin AxisName: SliderVersion: 65536min: 0max: 255center: 127nullzone: 0.05minzone: 0maxzone: 65535In my case, by changing minzone to 17000 and maxzone to 52000, I could increase the slider's span to 0% to 100% of the throttle.This other post recommended to change the nullzone parameter to 0.1, but this never worked for me.Anyway that was before, as no solution work today, and I am stuck with under powered airplanes that can not idle - or pressing keys to control the throttle !Thanks for any help, and I by the way, I also work in the OS group at Apple, tell me if I can help in any way.-Francois

Share this post


Link to post
Share on other sites

WAY COOL!! An real OSX expert! I know you wil be able to contribute significanlty.Unfortunately I am stuck in OS9. My old Beige is just too hard to make deal with X. I lurk on the Beige G3 forum at Apple Discussions and many of the users are not getting good results with X. Upgrading is an exercize in anger management for some. I'll wait for a new box to do X. However, on the off chance that I completely lose my mind, the new HD I installed at Christmas has a 7.999MB partition first-up....just in case.I think you are facing an X issue. The orig release of Fly! didn't support input devices under X, but 240 fixed it for most folks. Hopefully, one of the OSX flyers here will jump in and help. There's not a huge number of us on this forum, so answers don't always appear rapidly.BTW, I briefly tested Fly! II (we try to use the Roman numeral to keep it from looking so much like 2K, the original release) on my daughter's eMac 700 with 10.2. There, X did FlyII worse than my Beige, but booting into 9 gave impressive rates. It looked like Jaq did something to 9 that really boasted performance.Welcome. Glad to have you around!

Share this post


Link to post
Share on other sites

Allan,Thanks. I'll try to be useful. I'd swear that the slider problem is patch related as I tried booting back to 9 to fix it my old way, without chance. I'll be patient and hope for someone's idea.

Share this post


Link to post
Share on other sites

I have the same problem, only with a Saitek Cyborg 3D Gold. Also running patched Fly! II and 10.2.3. As you said, editing what's in Controls.txt seems to do nothing.Looking forward to figuring this out - it's the one thing keeping me from Fly! II right now.

Share this post


Link to post
Share on other sites

I posted this on the main list also. Let's keep this thread going and hope someone finds what triggered the problem. In the meantime I have redirected the Throttle UP and DOWN buttons to two buttons on my joystick. It's not as nice as the slider, but it works.

Share this post


Link to post
Share on other sites

Wish that would work for me - on my system, it's not just the slider, but every axis. You're (comparatively) lucky. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this