Sign in to follow this  
Guest

Dynamic Vehicle - Lights - Need Help !

Recommended Posts

Hello,Based on the research and work by Javier "Flight" Rodriguez et-al ...thank you all ... it really adds to the airport atmosphere whenthings are moving around you ! I have managed to get 2 airplanesand 1 little truck moving at the same time around a small airport !However ... ( there's always one of these "howevers" ...isn't there ),the models move great ... but I'd like to know if there's someway of making the external aircraft lights turn "on" ! One of my dynamic models is based on the "Flyhawk" .... and I have foundthe "FLYHAWK.ELT" file which defines the external aircraft lights ...but I do not know how to turn them "on". If someone knows howto do this ... it would be a great addition to the "dynamic vehicle"atmosphere ... obviously at night !A.S.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Were the planes moving in the proper direction? Whenever I try the plane goes backwards.How did you get two vehicles moving at the same time? What call did you make in the SCENERY file to accomplish this?I have been experimenting with this for some time and have only gotten the fuel truck to move. If you have two airports using the same Data file only one vehicle will move. Have you been able to overcome that problem?

Share this post


Link to post
Share on other sites

Hello Wayne,Yes, the planes ( dynamic vehicles ) were moving in the direction(s)that I had intended. Two of them are traveling clock-wise and oneof them counter-clock-wise ! I used 3 different .pth files to accomplish this. The dynamic models are referenced in the /Data/D123456 folder ... when I save the scenery from the editor,the corresponding SCENERYA.S11 file contains the model name(s).As for your plane moving backwards ... I have a similar situationwith a little FedEx truck, and I believe it has to do with the waythe model is drawn in the .tif file. I noticed that when I placedthe FedEx truck on the ground ...it was oriented "backwards" as compared with my other models that work correctly. Perhaps if youdevelop a different dynamic vehicle ...it will be oriented in theright direction ( I don't know how many dynamic models you are experimenting with ... I have about 14 which I am experimenting with.)I am not sure I understand your last question ( concern ) ... sorry.Remember that if you have more than one vehicle, when the SCENERYA.S11 file gets saved, it gets rewritten and you loose anyprior editing ( /file.pth ) that you may have done. So youhave to go back to the SCENERYA.S11 and make sure all the ( /file.pth ) pointers are set for all the models.I have created moving planes at two different airports ... haveflown in and out of the airports ... and I have seen the vehiclesmoving as I am taking off and landing - a bit challenging sincethe vehicles criss-cross the runway ... at one point I could notstop quick enough ... and crashed into one ! ... just one morechallenge to deal with ... it's a lot of fun !I would like to do a bit more testing ... and see if someone canhelp me with turning "on" the external lights for the dynamicairplane models before I upload my work ... and have you folksplay with it !Regards,A.S.

Share this post


Link to post
Share on other sites

Thanks for the response. As far as dynamic vehicles go I am only using the fuel truck with the Fly Editor. I don't know how to create a dynamic vehicle.After you upload your file I will look at what you have done and that should answer my questions. If not perhaps you will be kind enough to help.It would indeed be great to have several different types of vehicles moving around the airport. I made use of the fuel truck at the VNY airport and since it has no lights and also crosses the runway it can present a lot of excitement for someone landing at night.Looking forward to your file.

Share this post


Link to post
Share on other sites

For the Fedex Truck and those models that run backwards.. maybe if you select Reverse on the Loop options when creating the Path... I don't know I haven't tried yet.As for the lights... I know there is an option to FORCE LIGHTS under the Model Properties ( Screen Shot # 2 ) while using the Editor, I have used that and the lights of Fuel Truck doesn't work. BUT... I know you will need a special ACM file for the NIGHT MODEL so... there is the hint..Try creating a nigth model ( ACM ) file for your dynamic plane / truck and change it under the Model Properties once you select it ( see Screenshot #3 )First Screen shot shows a Static Model with Night Lighting.. keep in mind it is a static model, but the idea is the same, it has a special ACM / SMF file for the night.We are close my friends....Regards.Javier "Flight" Rodriguez.

Share this post


Link to post
Share on other sites

I kept searching... I think what triggers the lights of the Dyn Model is the ELT entry on the NFO file of your Dyn Model, I am not sure because I haven't tested yet... something must tell the Model to turn on the lights,mmmm... I just wanted to share..Will keep working...

Share this post


Link to post
Share on other sites

Hello Javier,Thanks for the ideas/leads ... I have not had much time totest anything new ! Hope someone zeroes in on this externallights dilemma ( for the dynamic models ...that is ! )I have found a strange thing when placing models. At CYVRVancouver ... and also at KRNO Reno ...it seems that if I placed a model close tothe airport buildings... everything seems to have worked OKin the Editor... but when I started Fly II again , and wentto the airport ... the models did not appear ( although all theassociated files looked OK. ) What I had to do was to place/start the models in the Editor in a location "far" from the buildings ... at the runways andsuch ... only then did the models appear and move correctly whenI started Fly II at the airport. It seems that if you place/startmodels too close to an existing building ... upon loading thescenery ... these "dynamic models" may not get loaded or appearat all in the scenery ... I don't know the reason for this...perhaps it has to do with the way or order in which things get loaded ... maybe one over-rides the other. Just a strange phenomenon ... the solution seems to be in starting/placing the"dynamic models" some distaceaway from any existing buildings.A.S.

Share this post


Link to post
Share on other sites

Hello Javier,Just wanted to post an update on my latest findings ...It seems that the only aircraft with "night" models ( as per your picture above ) are available from the BIBERALL.POD library. These do not have the externalflashing navigation lights, however ... these models just make the aircraft a little more visible at night.I extracted the "B737_American" TIF and SMF files from theBIBERALL.POD ... modified the MODELS files and created a new dynamic library which included the following:ARTBS37AA.TIFARTBS37AAN.TIFMODELSBS37AA.SMFMODELSBS37AAN.SMFWORLDBS37AAN.SVHWORLDBS37AAN.NFOWORLDBS37AAN.SFXWORLDBS37AAN.SITWORLDBS37AAN.LODThe major change was made to the "BS37AAN.LOD" file ...to include the "night-time models" section ... please seebelow for the example. -- Begin File -- /////////////////////////////////////////////////// // // Visual Aircraft Models // /////////////////////////////////////////////////// ---- daytime models ---- ---- begin models ---- ---- model entry ---- comp BS37AA.SMF ---- end models ---- ---- night-time models ---- ---- begin models ---- ---- model entry ---- comp BS37AAN.SMF ---- end models ---- -- End of File --When placing the model ... it transitions nicely from dayto night. The only unfortunate situation is that it seemsthat all the models are placed "backwards" on the scenery ...the nose points down ...instead of up ( as do the other non-biber models ). So when I generate a path... the airplanetravels backwards ... if I set the path for "Reverse Loop"the airplane travels backwards first ... and then in reversesand travels correctly with the nose going forward. Then it starts the entire cycle of going "backwards" before it goesforward again. This is not ideal ... and I am not aware of any other path settings that will make things look better.So it seems that if the biber models were redone ... and oriented"properly" ... then the planes would travel correctly ... and"night" dynamic airplane models could be available ... which would make them easier to see. I would still like to know how to generate the flashing external navigation lights ... but some airplane "lighting" at night is better than nothing. I do not know how to redo the existing biber-models so that they are oriented "correctly" ( for the paths ). I have tried modifying the TIF files ...notknowing exactly what to do ...but my changes have no effect.I have read something about a Z-axis... but I do not have anyknowledge of where and how this is done or chaged.I think more importantly ... the MODELS files .SMF or ACM are the key here. With my system I can not press the "Ctrl" key and startFly II in order to get to the Shape Editor Functions in Fly II...where I think the utility to generat MODEL files is located. My system crashes whenever I try to start Fly II with the "Ctrl" key depressed ... so I have no access to these additionaltools to experiment with.So, for now ... I have a "backward" moving dynamic "night"aiplane model... which is not very visually realistic or desirable. Regards,A.S.

Share this post


Link to post
Share on other sites

Hey! nice to see some progress!It seems we are in the same loop, I know as much as you know ( I think ) since what you explained is the same I would do.. I mean play with the .LOD file, use Night Models, etc..As for the External Lighting on the Night Model... the only thing I have tried lately is to include is the ELT file on the POD file for the particular Model ( for example the B727 Northwest ) but it is not intelligent enough to know when it is night and then turn the lights on, I need to find the way to trigger the Lights at night.. automatically.That only take us to the Dynamic Airplanes Models, the ones TRI uses for its AI Traffic, they seem to work pretty well at night, the key is under the acgeneric.pod, the signature tag ( needs to be PLAN no GVEW under the NFO file and the ELT file ( needs to be called )I haven't got too much time to keep searching, but I will use any spare time I get.Regards.Javier

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this