Sign in to follow this  
Hans_Petter

Models

Recommended Posts

I'm populating the London City airport and looked through the models of Seattle and SanFran to find more models to use. I found quite a few but unfortunately most of them were in the Seattle folder. Well, I figured I might try to change the palette of the brick buildings that I wanted. There's also a couple of red cranes and whatever color they might take on with the SanFran palette would probably be OK. I made a list of the ones I wanted and browsed through the GEN folders to scoop them. That was when I found out that they're not available as single BINs and MIPs -- they're in modelmip.tag!So, how do I extract models from modelmip.tag? best regards,Hans Petter

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello Hans,the tools you search for must be:tagseek.exe, tagview.exe, tagwrite.exeThey were available a long time at an old page of Tomi Lehto. But it seems this page is closed now. So I send you the needed zip-file direct. If you check your mail the problem should be solved for you.Best regards :)Ansgar

Share this post


Link to post
Share on other sites

Three .exe, yes, well, there is that way too.@-@

Share this post


Link to post
Share on other sites

Thanks, I'll check my mail!Since I wrote that first message I downloaded Adamski's seamodels.zip and took a look at the Genfled_sf subfolder. These files are using the Seattle palette and are meant to be used with Adamski's "dual palette procedure". However, my UK South is a totally stand-alone sim and I'd like to keep this way. So, I've just spent a couple of hours repalettizing these to the SanFran palette. They all look fine in ModelView. Most importantly, I've got the red cranes and the little brick houses that would fit the English scenery.I might upload the repalletized Seattle models but the ones that I use will certainly be included in the new London City package.By the way, the Big Red is ready to fly. Expect an upload tomorrow!Hans Petter

Share this post


Link to post
Share on other sites

A few issues, findings and questions:After repalettizing all those Seattle models I found that I'd made a few mistakes. Some mips where skipped and ModelView told me what to look for. Others came out with a size of 0 kb. In this case ModelView did not complain but of course, the objects had white, untextured parts. I redid those and got all of them right except for one. The roof of capital0.bin gets corrupted when I repalettize it. The only way to keep this one sound and healthy is to keep the Seattle palette for that texture. Alternatively I might make a 0 kb texture and get a white roof.First question: Do I risk anything by dumping all of these objects into my UK South GEN? I don't think that they'll overwrite anything and if they try I'll say "no". I'm just concerned that misbehaving models may freeze FLED or the sim. For instance, what happens if a mip is corrupt or missing? If things don't display properly that's OK since then I can fix it. Strange crashes and freezes are what I want to avoid at all costs.FixMip doesn't purge an image when I've repalettized it. If all images are the same size or the next one to be processed is larger everything's fine. Problems arise if I try to "fix" a small mip after having "fixed" a larger one. If so, I get the little mip embedded in the previous larger image and the file gets corrupt (wrong size). The way to avoid this is to close FixMip and relaunch it for every mip. Maybe there's a way to make FixMip drop the previous task and start with a clean slate?I found a nice dome that seemed to fit next to the London City airport(kingdome0.bin). I put this bin and its mips into my UK South GEN and placed it in FLED. That's when I found out that it was way too big. I'll be looking for a similarly shaped dome or park pavilion.Anyway here's a couple of images showing what I'm working on. The big pavilion on the hill will be replaced and buildings will be added on the south bank (left of the runway) and on the spit of land in front of the runway.best regards,Hans Petter http://forums.avsim.com/user_files/16968.jpghttp://forums.avsim.com/user_files/16969.jpg

Share this post


Link to post
Share on other sites

You can test the models in FLED first. If FLED can't find MIPs that it needs, it crashed with an error message telling you what it can't find. In that way, you can work out what is missing and fix it. But FU3 does not crash as gracefully - so it is best to work out the bugs in FLED first before trying in FU3.Glidernut - I loved your suggestions! Robd.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this