Sign in to follow this  
Guest olympic2

"Assertion Failed" message ?????

Recommended Posts

Greetings all,After loading Cardiff, I am receiving a Windows message advising that "Assertion Failed" while the AI Startup is on the desktop.The attached image will give you the full message text.This message pops up at different stages of the AI Startup, but only on that screen. If I select the "Yes" option, the desktop loses the background map, goes black and the AI tracks continue to load up to 99% and then FU3 proceeds to run normally.If I select either the "NO" or "Cancel" options, I crash back to the desktop.This has only commenced since loading Cardiff, and I have the Stanstead, Heathrow and Gatwick AI loaded. I an running WinXP Pro, 1.2GHz processor, 384Mb RAM, an ASUS V7100 series video card with 32Mb memory.Any thoughts.**Sorry - the image has not loaded - not sure why.The full text of the message box is:QUOTE"Assertion Failed""Translation expected 264, but found 1008(File: engtrans.c, line 176)(Yes to trap, No to exit, Cancel to ignore) YES NO CancelENDQUOTE

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

There's nothing wrong with Cardiff, but it sounds like your AI/ATC is out of step with your installation. You may be able to continue loading by just hitting ESCape when this screen pops up.I am trying to get a stable version of UKS made but am getting very little help at present. My version is 100% stable, and everything in my version has been uploaded to the web many times - to the forum, to FTP sites, to AVSIM. I can't see why its so difficult to get a proper working version. I'm not blaming anyone - it seems UKS has been dumped in my lap (since my version works) but I know little about FU3 outside of making packages! Anyway, I will keep trying to find a stable solution that can be transported to other computers.

Share this post


Link to post
Share on other sites

I agree (that it's something to do with your AI settings). As you add more airports (or update existing ones), it is necessary to update the associated files. If you don't, your AI may be weird or not work at all and you'll get error messages. I've had the same messages during flight :-eek The trick here is to always 'cancel', or you'll get a CTD. During the AI loading sequence, hit 'accept' and/or hit 'ctrl'+'break' or 'esc' to get past the error.I encounter this a lot as I'm always playing with aircraft or new models and rarely get to 'fully' update my airports. Every time I post a screenshot of a strip, someone (usually Chris ;) ) points out that my strip is out of date!Rob,We'll get the stability sorted real soon (as soon as I get off my bum and grab the HD back...). I'm looking forward to it, as well as getting a good Switzerland happening (mine is flat and holey). Do we know if it's possible to improve the terrain mesh like Andre is doing with Switzerland? My creeks are flat and my meadows just slope :-erksBTW, the forests are done - I'll post some shots soon. I was going to include them in the 'ntree upgrade' package. There are two sets for each region (Seattle, Sanfran, UKS). Set 1 uses 'ntree1', set 2 uses 'ntree2'. For UKS, the trees are slightly different (but again, match up with the new UKS 'ntree1' and 'ntree2' sets.PS Looks like I'll be on holidays next week (due to work schedules, I cannot take them when I originally wanted) so we can DEFINITELY meet up!:-waveRegards,**************Jonathan Point**************"I'd rather be down here wishing I was up there than up there wishing I was down here"

Share this post


Link to post
Share on other sites

Rob, JohnathonHi, Cardiff itself is fine - I have no problems with it other than a slow frame rate - guess that all those trees, radars turning and helicopters getting in the way occasionally. But I can live with that.I did notice a engtrans.dll in the main FU folder and when the AI stops the "Trap" option creates a engtrans.log file. I guess you people would be more familiar with that and its contents than I am.Unfortunately it does not contain 176 lines and I do not know what the significance (if any) on the .c extension on the error message.What I intend is to remove all airfields that have AI activity, load a blank AIPLAN.txt and AIMODEL.dat file and then load the airields one at a time and see how I get on.I will keep in touchCheers

Share this post


Link to post
Share on other sites

Thanks Jon - just letting off steam. I know everyone is trying hard to get this fixed and just ignore my comments there.The ENGTRANS file is, as you said, simply a log file full of info for LGS to fixup any bugs. But its a wee bit cryptic for me. I delete it once in a while, or it keeps growing.You can always disable AI for the moment, either in ALT-options or in the flt3.cfg file directly. Also I can upload a simplified AI as a temporary solution. No guarantees, and you won't get your money back if it doesn't help.http://forums.avsim.net/user_files/70158.zipBackup your files in regionsUK-South first. Then unzip these to replace them. These files are the simplest AI I could put together, with 5 nm circles around key airports and many defaults. Later I hope we can replace this with a more sophisticated UKS region, but my concern is just to get a working version first.RobD.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this