Sign in to follow this  
Guest sonreir

Problems with Logitech Force 3D Pro and PMDG 747

Recommended Posts

Hello,i need some help. I have the Logitech force 3D pro joystick and the PMDG 747. But both together don't work in a perfect way. For example, after takeoff, passing roughly 1000ft, i engage the autopilot with LNAV and VNAV. Well and my joystick starts to move a little bit forward ( nose down ). And while he is moving forward the autopilot turns off automatically, and i have to fly manually. So i pushed the autopilot "Engage" button again....and again the nose moves slightly down ( like the forece feedback joystick)...and again the autopilot turns off automatically itself. Well and that's not good, to engage the autopilot during climb for about 10 times...:((((( And trust me i have the right trim. Also i tried to trim before engaging the autopilot in a way so that the autopilot has nothing to do...but then this happens during increasing or decreasing speed, or even if there are a more stronger turbulences.Well, in fact, i don't know what i can change in my configurations, both Joystick and PMDG??:(((I tried also the PMDG options with the "AFDS Controls Override"...and i hit the button " Elevators/Ailerons/ Rudders"...and for the first moment i thought it works...but this was more worse. Because the autopilot starts to think that every little move of my joystick is my own movement...so he started to increase his climbing rate or his descending rate all the time, up and down...:((((And the options of the Joystick are all "Standard".Well the problem is, that the joystick moves itself all the time, during climb and descent, not much, but you can see that. And PMDG thinks all the time i try to make a movement and disengages the Autopilot. So i need something that i can touch the joystick without disengaging the autopilot all the time. But of course not this "Elevator...Rudders" Option ,...because it has a much more worse effect.I hope someone can help me,...Thanks in advancewith regardsLukas

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Lukas,Force feedback (FFB) and the autopilot does not go along well together. Any movement on the joystick (by you or the FFB mechanism) and the A/P will disconnect. Disable FFB and you'll be good to go.Hope it helps,

Share this post


Link to post
Share on other sites

Hi Mats,thx for fast reply. Just thought about that, because that is a big problem with FFB and the autopilot. Thanks.Lukas

Share this post


Link to post
Share on other sites

Hi Lukas,In your configuration settings if you can stiffen the spring that should help too. I have a Saitek Cyborg 3D FFB stick and upon setting spring settings to max the stick stiffens up and also gives the FFB effects.Hope it helps.- Jay

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this