Sign in to follow this  
Guest

Scenery/graphic problems

Recommended Posts

Hi everyone!I have an very big problem with ms fs2002pro.I have winXP pro,geforce2-400mx with 64mb,pentium4 1400,512mb RAM...My fs2002 pro was runninig just fine.Now I got a problem.When I choose an airplane and a flight and click on "fly now" everything loads ok (all 100%) and then it starts:I get message(s):"Scenery load error!Attempting to open a nonexistent directory:C:Program FilesMicrosoft gamesfs2002(and then some funny signs).Press OK to continue"and so several times.And then when I start flying the most of scenery is missing.Like I said fs2002 was running just fine on the same computer.Problems started suddenly.I tried to reinstal fs2002 I even formated my disk and instaled windows and all again but I still have the same problem.That's why I can't figure out how I can solve this problem.I thought reinstal and that's it.But like I said-it does not work.If anyone could help me I would be really thankful.Fly good and thanks for any help.:'(

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Rivle,I to am having the very same problem, same error messages. I thought it was me and have tried the same things as you but with no results. Only differance is I'm using Win 98SE, PIII 550, everything else the same. Hope some has a fix!! I to will be gratfull for help!

Share this post


Link to post
Share on other sites

Here's a checklist that should help:1) Did you do a full installation? If yes, continue on.... If No, uninstall FS, deleting all the program folders, and do a full installation!2) Did you add any "add-ons" prior to running FS after the reinstall. If No, continue on.... If Yes, uninstall FS, deleting all the program folders, and do a full installation with no add-ons!3) Did you try deleting FS2002.cfg, then starting the sim. If yes, continue on. If no, then delete FS2002.cfg and restart.4) Have you scanned your Hard Drive for defects? If yes, continue. If no, scan your Hard Drive, including a full surface scan. That would help identify if the missing directory is actually a corrupted one.If you've made it to this point, and still have a problem, let us know... There's a few more steps we can try....

Share this post


Link to post
Share on other sites

Yes I did it all but nothing helped.I even formated my hard disk,instaled windows and all programs again (including fs2002 pro)but I still have the same problem.First error messages,then when I take of scenery is missing,some lines are appearing on screen (I mean some peace of aircraft or airport is staying on screen) and I also become error message(s) during flight. I just reinstaled fs2002 for x'time and nothing got better.I don't understand how this problems can stay even when I formated disk and instaled everything again!?Some new ideas?

Share this post


Link to post
Share on other sites

Try to think about what changes were made to your system just after your last "good" FS2002 session. Did you change any hardware? Did you visit any new websites? Did you lose the power? Did you uninstall or install any software? Also, don't waste your time reformatting...sometimes its indicated when you have a damaged graphics or io subsystem, but not for the type of problem you're having.This next step will take some work. Go to the FS2002 folder.... Locate the file called Scenery.cfg. Every folder mentioned in that file should be present on your Hard Drive, within the FS2002 folder. Also, no entry should exist anywhere after the "remote=" lines. If so, FS2002 will think that you haven't done a full install. If you need help, just paste the contents of the file into the thread.... Scenery.cfg is where FS looks to "know" what scenery to load. That might point to the problem....-John

Share this post


Link to post
Share on other sites

I checked Scenery.cfg file.All files are present and on the right place.I didn't changed my computer configuration since I bought it.About software...I'm not sure.I think I have not installed anything after fs2002.Even if I did it could be something smaller.But I think I didn't.Thanks anyway for your help.

Share this post


Link to post
Share on other sites

Like I wrote in the first message:When I want to fly (also with default cessna & Meigs) I choose airplane,airport(s),then I click on "fly now" and computer then loads scenery,AT and everything it needs.There is all OK.It loads all 100%.But then when it should show the cockpit screen stays black and error message comes:"Scenery load error!Attempting to open a nonexistent directory:C:Program FilesMicrosoft GamesFS2002(and here some are funny signs no words.Like when it's on the language computer does not support).Press OK to continue."That is the message I get.And so 3-4 times.Then it shows cockpit and I can fly.It shows airport,buildings,airplanes but it does not show land.It's all mostly brown.And when I fly I get message:"Scenery load error!Attemping to open a nonexistant directory"Then I press OK and I fly further.It happens with all airplans,all airports and on different continents.So it shows everything but (I think the english word for that is) landscape.That's it.

Share this post


Link to post
Share on other sites

Sounds like we're getting closer to the problem. This is an article I wrote for the tips page--it talks about doing a manual installation of FS2002 on a Windows 95 computer, but it will work for you. Use it to verify your installation, especially the parts which talk about the scenery. In the article, I include an example of what your scenery.cfg should look like. The article assumes you install FS2002 on your C drive. Here's the link:http://www.fsgateway.com/tips_read.asp?id=285

Share this post


Link to post
Share on other sites

This is very complicated.I checked my registry and it all matches that what you wrote on flight sim except langid.You wrote:"LangID"=dword:00000009and by me it's:LangId (type:)REG-DWORD (data:) 0x00000009 (9)Can that make some problems?

Share this post


Link to post
Share on other sites

No--you don't have to worry about the registry. I think the problem is missing scenery or a bad file in either your scenedb, or in FS2002Scenery. One quick thing to try...paste the contents of my example scenery.cfg into notepad, then save it as a new scenery.cfg. Try running FS again, and see if you get the error....

Share this post


Link to post
Share on other sites

I tried it but it doesn't work.I got a message:"Scenery READ error.Attempting to open a nonexistent directory." (without any specific folder named).Earlier I got message "Scenery LOAD error...".Well,tommorow is a new day.Stay good.

Share this post


Link to post
Share on other sites

I'm gonna try to extract scenery files from CD and then replace these in fs2002Scenedb folder.If some file is corrupt it should work then.(That's just an idea).Stay good.

Share this post


Link to post
Share on other sites

I solved the problem.I uninstaled fs2002,cleaned boot and then instaled game again.FS2002 is running good now.No more error messages.Special thanks goes to JohnCi.You really helped me.Thanks again.Stay good.P.S.Alex 3 that has the same problem.Just do what I have done.Read the messages and find link to microsoft's support page (URL posted in the message by JohnCi) and then follow instructions.Good luck.

Share this post


Link to post
Share on other sites

Rivle,Glad you got your sim up and running. I will give it a try tomorrow evening. I think I did this once before and it still didn't clear up the problem. If I might ask, when you clean booted did you have any other MS games loaded on your PC? Again, glad JohnCi was able to hang in there and work with you. Happy flying.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this