Sign in to follow this  
maverickr

Not Enough Memory

Recommended Posts

Wondering if anyone out there has had this message "Not enough memory available to complete this operation. Quit one or more applications to increase available memory."? I get this message after adding third party scenery to my main scenery folder and am pasting exclude switches to the scenery area in the scenery.cfg.It seems I can add all the scenery I want, it just won't accept the swithes anymore. I have also tried manually typing them in but get the same message. I run 2K2 Pro on a 800 P3 with 512mb memory. I've also used End It All program to no avail.Thanks in advance,Mike

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Never install third-party scenery in the FS2k2 main scenery folder. Always put it in the ADDON SCENERY folder. That may well be your problem.

Share this post


Link to post
Share on other sites

There is a limit to how large a file notepad can handle, try using wordpad.Kurt M

Share this post


Link to post
Share on other sites

Kurt,I wish I knew what kind of memory they mean when I'm told I'm out of it. I have no problem adding more scenery through the scenery library. It's just adding the switches AFTER the new scenery is added to my scenery.cfg file which is in the form of notepad.How would I change everything over from notepad to wordpad and would 2k2 recognize the new file?I'm totally lost on this one.Thanks,Mike

Share this post


Link to post
Share on other sites

Mike,2K2 couldn't care less if you're using notepad or wordpad to edit files. Kurt misunderstood the problem.Firstly, are you sure the add-on scenery does not already have exclude areas? Most I add does, and all the scenery I make has it built into the bgl files.Secondly, I had this problem occasionally but never could pin it down. It appeared to have something to do with my video card, but I can't be sure. I do also run out of memory when I go in and out of 2K2 when in full-screen mode. It's irritating and I don't know why it does this. 2K2 has a lot memory leaks as it is.But I digress.Perhaps you are defining a much-too-large area. Make sure you are defining the exclude area in the format FS expects, or you could be excluding all the scenery in the world - less the area between the two definitions. ;-)The Exclude switch syntax is as follows:Exclude=North Latitude, West Longitude, South Latitude, East Longitude, category

Share this post


Link to post
Share on other sites

Mike,Maybe I misunderstood your problem, is this happenning when the sim is running or when you are trying to edit the .cfg file? If it is happening when you are editing the .cfg in notepad, it may be because of notepads limits.------------------Microsoft Knowledge Base Article - Q59578 Maximum File Size Limits for NotepadSymptoms-You may receive the following message when you open a file with Microsoft Notepad: File (filename) is too large for Notepad; use another editor to change the file -or- The following error message may be displayed while you are editing a file in Notepad: Insufficient memory to continue this operation Cause-Text files used by Notepad should be no larger than 45K. Notepad cannot open a file that exceeds 54 kilobytes (K) in size and does not allow you to continue editing a file if the file size reaches between 45K and 54K. Workaround-Use another text editor to edit the file.------------------If this is the problem, you can open wordpad from the shortcut in the start menu and browse to the .cfg file and open it or if you normally just double click on the .cfg file and it opens in notepad, just click once on the file to highlight it, then press and hold the shift key and right click on the file. You should get a Open with... option, choose it.http://ftp.avsim.com/dcforum/User_files/3d68c337019a7bda.jpguncheck the (always use this program to open this file) box and scroll down and select wordpad, hit OK and the file will open in wordpad.http://ftp.avsim.com/dcforum/User_files/3d68c35701ec3ce3.jpgKurt M

Share this post


Link to post
Share on other sites

Scott and Kurt,The author of the 3rd party scenery did not include the switches in his file so I had to add them at the end of the area in the scenery.cfg. I have no idea what the parameters are or how big the area is that needs to be excluded, but I understand what you are saying. I did take the advice and opened scenery.cfg with word pad and was able to paste the switches that way. Everything is working fine now. Don't know why notepad doesn't have the memory capacity as wordpad, but as long as it works, I'm not questioning it.Thanks to both of you for your ideas and quick responses.Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this