Sign in to follow this  
iwik

Elevator Trim indicator with Fsbus

Recommended Posts

Hi All,Has anyone used FSbus Servo bd to show trim position.I have attempted to but i cannot get it to work the way it shows in the panel.I have the Flap indicator working ok but this controll has range of 0 to 16383.The trim value goes from -16383 to + 16383.The servo wants to travel its full range from Neutral to say nose up.Then when it gets to neutral again and hits a negative value the servo goes to the opposite end and completes a full travel for the section between neutral and full trim.In a nutshell what i am saying is that you cannot have the servo start at one end and go through neutral to the other end in one continuous movement.The way it does work,the gauge moves in the correct direction but the neutral position is not in the centre. Appreciate any comments.Especially anyone who has accomplished this.Thanksles

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Have you modified the MIN and MAX values?They should be respectively-16383and16383

Share this post


Link to post
Share on other sites

Thanks for the reply,yes i have values as you stated.It seem that the servo takes each section(16380 to 0) and covers the full travel.The negative value just causes the servo to reverse and then it covers the same range.very starnge.Obviously no one else has tried to use it.maybe i will email Dirk.Les

Share this post


Link to post
Share on other sites

I just tried using an analog for the trim, and it is very jumpy: complitely unusable. FSBUS writes all sort of garb to fs just not the values right for the trim.Maybe there is something wrong with the whole trim thingie...

Share this post


Link to post
Share on other sites

Les if you get any information about this, can you please report them here?I was just drawing my setup to use a servo for trim indicator.Thanks

Share this post


Link to post
Share on other sites

Hi Claudio,I now have my trim indicator working.I cant take the credit,a friend of mine played around with the numbers and here is what you enter in servo section.Multiplier 0.0078Offset 128Min value 0max value 255I use a rotary Encoder followed by Redec for the trim adjustment.This works very well and now with the indicator all is SWEET.Hope This helps.Les

Share this post


Link to post
Share on other sites

Should have understood it myself :(Well thank you anyway :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this