Sign in to follow this  
Guest

FS2002 freezing after a few minutes...

Recommended Posts

I've got a strange problem that I can't figure out. I just built a new PC:Athlon 1900+Soyo SY-K7VTA Pro mainboardGeForce4 Ti 4200 64 MBusing onboard audio (AC97 chip)384 MB PC133 SDRAMEverythig runs great, all of my games and apps run without problems, except for FS2002. It will boot fine all the way into the 3D sim where it always hangs after a little over a minute. Whether I start flying or just sit on the runway, it will always lock up the entire PC (no alt-tab or CTRL-ALT-DEL), the sound also stops with total silence. If I go into something like FSNAV, it won't lock until I go back into the 3D game itself, it is almost like it locks after a certain amount of time drawing the 3D world?I've tried changing the AGP aperture (and even disabling AGP altogether) with no success. I searched the forum for something similar and didn't find anything, so I am looking for ideas. I would hate to have to go back to my old PC just to play FS2002... :(

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Just an idea, as it only occurs on 3D views. You probably have mixed up drivers. I guess Nvidia has changed some of the patch with the new drivers so a lot of people obviusly get stuff mixed up when installing and uninstalling new drivers. Try the following:As for your problems I am quite sure that they are triggered by mixed up drivers although I do not know about the GF2 and typical problems that may occur with that card.Uninstall the Nvidia drivers in your system /software page. Do not reboot yet. Go to your Windows/Inf folder, and find the files nv3.inf and nv4.inf. Rename them nv3.i_f and nv4.i_f. Extract the driver to a known location, e.g.: C:/Nvidia. The 40s will do that by default. Do not install the driver yet!!Restart your computer. When the wizard comes up, lead it to the new drivers folder. Return the nv4.i_f and nv3.i_f to their original names incase of a problem windows will still install the default XP drivers.This is just a wild guess. Can be 1000 things. But definitely worth a try. Helped a lot of guys already.Alex

Share this post


Link to post
Share on other sites

My setup is a GF2ultra and I used to get lockups in FS02 (reboot via pwr button).My fix for this problem was to set AGP to 1X mode (instead of 4X or "turbo") using the Via chipset driver.No lock-ups since then, and 3DMark numbers didn't change that much to make a difference. Pat

Share this post


Link to post
Share on other sites

This could also be a heat problem. I had this issue with Quake and Buddy had it with FS2002. You may want to open your case and have a house fan running blowing into your case...

Share this post


Link to post
Share on other sites

Hi Pat,this may have well solved your problem, but something must be wrong with your setup or hardware here. You should not be required to set your AGP to 1x on a well configured rig.Alex

Share this post


Link to post
Share on other sites

OK, some more info. I am using the latest Nvidia det. drivers in Win98SE. Tried re-installing the drivers like said above, problem still persisted. Tried lowering AGP to 1X, no change. I didn't think it was an AGP problem since I disabled it altogether before with no change.Then I just tried messing with stuff to see what happened. I tried turning my framerate setting in FS2002 down to 25 max (I previously had it set at unlimited) and BEHOLD, I had a flight last almost ten full minutes until the same type of lockup occurred! I did a few more flights after rebooting just to see if it was consistent and it did appear so, flights now last about ten minutes before crashing. I can

Share this post


Link to post
Share on other sites

>OK, some more info. I am using the latest Nvidia det. >drivers in Win98SE. Tried re-installing the drivers like >said above, problem still persisted. Ok, which drivers are you using, version #?Have you tried older det drivers?Have you re-installed the M/B chipset drivers after installing video drivers? This is most important.JulianNZCH

Share this post


Link to post
Share on other sites

I'm also experiencing the same problem but not for long. I've been using FS2002 for almost 10 months now with out any glitch till now. I haven't upgraded my pc except the ram from 128 to 256 mbs. I'm experiencing lockups after every 6 to seven minutes. I also sometimes get a dll error. Sometimes its a terrain.dll error or sometimes its a g3d.dll or a g2d.dll error. I've formatted my hdd some four times, installing windows and fs again but to no avail. I think I must be going mental but I can't seem to resolve this problem. I have both windows 98 and windows XP Installed and am having the same problem on both OS. I have the following basic system.Intel PIII-800 ( 133MHZ )Intel 815EEA Mother BoardTranscend USA Ram 256mbs ( pc133 )Prolink GEForce 2 MX400 32 mb ramCreative SBL live Value! Sound CardWindows 98 and Windows XP ( Both Installed ) I would dearly appreciate your help in this regard

Share this post


Link to post
Share on other sites

I agree, something is wrong. It only happens on FS02, other programs do not lockup. Since it does not really affect frame rate, I'll live with it...Pat

Share this post


Link to post
Share on other sites

Mengy,Your CPU temps look OK but make sure you either measure them in real time or within a couple of seconds of closing FS2002. If you run an indicated 122 farenheit then this probably puts you at around a true 80 degress celsius (that is using AMD's rule of thumb conversion for mainboards that do not employ the new Thourougbred sensing diode standard). That gives you a safety margin of 10 degrees celsius which should be fine.I was actually in a similar situation to you having recently cobbled together an Athlon XP 1800+ system to tie me over the next 8 - 12 months. Even though I stability tested it with 3D Mark for 48 hours straight without lockups, it locked up with FS2002 after around 5 minutes. After changing one system setting at a time (including FS2002 display settings), the culprit in my case turned out to be the aircraft texture size. Having a Geforce 4, I thought setting it to "massive" shouldn't have even remotely been a problem. Once I set the slider to "high", all the lockups disappeared. Why the massive texture size causes problems with a Geforce 4 is difficult to explain, but this was the culprit in my particular system.There are also a few performance BIOS settings on Athlon boards that can cause chronic instability, even though the performance gain when setting them is neglibile. If your BIOS has some sort of default "conservative" setting, firstly enable this.If I was trouble-shooting this sytem myself I would also look at the onboard sound straight after verifying the temps. Go into the BIOS and actually disable the OnChip sound. Then see if your lockups disappear.As Alex correctly pointed out, there are 1000 things that can cause lockups, and the only way to solve them is to methodically change one setting at a time until they disappear. But you can save yourself a lot of time by going conservative in the BIOS settings, then performing another clean Windows install followed by a clean default FS2002 install (no add-ons, no nothing until you solve your lockup problem). That gives you a nice clean sheet from which to work from. Frankly, if none of our sugestions work and if you don't do these two clean installs you are most probably going to be chasing your tail figuring this one out.

Share this post


Link to post
Share on other sites

Hope you solve it. When I say heat problem, I am mostly refering to your video card heat, not the cpu. It easy to test, get a house fan....

Share this post


Link to post
Share on other sites

I don't use the Soyo mobo or onboard audio, but I had the same problem with my Athlon 1700 in an ASUS mobo with Turtle Beach Santa Cruz audio (more specs in my profile). It was really frustrating because my desktop computer was running fine on all other apps (games, video editing, image editing, etc.) but crashing in fs2002, usually when I cycled views (cockpit-->virtual--->tower-->spot). The solution for me was similar to what the last couple of folks posted - I turned off the AUDIO acceleration and it never crashed again. I occasionally re-enable it because I get a few more dB's of volume from the soundcard so I only crash in fs2002 now when I forget to disable it again. Good luck, let us know how it turns out.

Share this post


Link to post
Share on other sites

Hi Guys,I first turned down the Hardware acceleration. It helped, but that didn't solve it completely. Here's what finally solved the hangs completely. I now run FS2002 with no programs running in the background except my firewall. I do utilize FSNavigator and METEO. It's possible that my Anti-virus program might have got twisted around the axel with Meteo jumping in every six minutes. (just a thought)By the way, my setup is ancient by todays standards. I don't know whether that's good or bad. For instance:P111 @600 MHzATI 128Rage (32meg)256 RamSound-Blaster Live sound card

Share this post


Link to post
Share on other sites

Yes these sound cards can sometimes be really cantankerous. Cornclose first picked up on the problem about decreasing the acceleration a long time ago and it worked for a lot of people. I think this thread put the curse on me, however, because a day after it was posted I was getting lockups again myself. I never ever had FS2002 lock up on my old PIII machine. My new Athlon XP runs absolutely every other application with perfect rock-solid stability. But now I have the random lockups as well in FS2002. First thing I tried was to pull out the Soundblaster Audigy. This certainly helped, but still lockups occur whenever the view was changed, even if it amounted to panning. My theory is that changing views causes a change in the soundmix (because your "ears" move with your head) and this change in sound mix causes the sound subsystem to crash (obviously only on particluar setups though). I only just started to experiment with "standard" sound acceleration for a few minutes late last night, so I don't how how well it worked. I know I ran FS for an hour yesterday (without sound enabled) and I experienced no lockups at all.It was interesting though that the lockups were very few and far between when using the stock MS aircraft. After I installed Bill Lyon's Tiger Moth, however, the lockups became frequent. After I installed the Waco, the lockups occured as soon as I even moved my virtual "head" at all in this aircraft. Obviously this doesn't have anything to do with Bills' wonderful planes, it's just a problem I need to sort with my system. I guess I am lucky though that the problem is easily repeatable on my system, which should make it easier to sort. Maybe... I'm actually going to try another thing later this week when I get the time. That is to reload Windows with ACPI disabled. You never know. Doing this has solved two big problems I had in the past so it's worth a try.

Share this post


Link to post
Share on other sites

Hi,I hope you solved your problem. If not you might want to check your system memory. [www.memtest86.com:www.memtest86.com] is a good tool for this. I had similar lock ups, after many things I checked it turned out to be a wrong memory timing setting in the bios. Thomas

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this