Sign in to follow this  
pastorpilot

Can't Solve DX-10 Tearing/Wavy Image Problem ...

Recommended Posts

Friends,Under SP-1 The image on my LCD monitor was perfect, with the exception of a few blurries which usually all filled in prior to my airplane getting to that location.BUT with SP-2/DX-10 Preview I am getting a wavy image whenever I move the view around. Its not unusable, but not perfect. It makes me feel almost a bit "woosy" to keep watching it. Like looking through water... and there are "waves that cross the screen." It WAS NOT present under SP-1. Also with SP-2/DX-9 this problem is NOT resent, the image is rock stable. Butut when the DX-10 Preview is enabled the image distortion is noticable. Does anyone know what there could be about SP-2 that would cause this? And any cfg entries that would eliminate it?I have forced on V/Sync in both the Control Panel and nhancer... but no joy. It doesn't seem to be making a difference.I have tried locking my frame rates at 15,30,45,60 but no help there.Does anyone have any ideas to share on this? Thanks so very much,SteveI am using an E6700 at 3.6 ghz; EVGA 8800GTX, 680i MB, 4 GB Crucial Balistix RAM at 800mhz, Samsung 226BW

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thank you for your kind response, Jaap.I will try adding the SP-1 line that Phil mentions. Thanks for the hint. I hadn't seen that. I will try anything!! You said,"Did you force the Vsync changes as AdministratorI think I am the "administrator." I disabled the deal in Vista that asks you every time if its okay to do this or that. I'm not a computer whiz at all, that's why I'm here! ;^) How can I find out if i have "forced the Vsync changes as Administraor?Thanks, and have a Happy Thanksgiving if that applies! (not sure where you are)Steve

Share this post


Link to post
Share on other sites

I tried Phil's SP-1 entry:[DISPLAY]ForceFullScreenVSync=TrueNo changes. What I was wondering, if this is just a characteristic of my TFT Samsung226BW monitor? But no, I don't think so. This ONLY happens in DX-10 Preview mode. Image is rock solid in SP2-DX-9 mode. Steve

Share this post


Link to post
Share on other sites

Hello Steve,Don't know if you have solved your issue yet, hope so though.If not, what driver version are you running?.Regards,

Share this post


Link to post
Share on other sites

Wayupthere ....So good to hear from you. I hope you are well.I am currently using NVidia Beta 169.12. I have tried every beta lately and also whe WHQL... 163.75, I think was the number.I can't find anything that will turn on VSync in DX-10 mode. Others say that there is no NVidia driver that will turn on several functions in the DX-10 Preview mode.If you know of anyway to get VSync to work, please let me know. I have given up on DX-10 for now. VSync works in DX-9 mode. Image is very solid. Unfortunately, it is still tearing and wavy in DX-10.Thank you for your reply.Steve

Share this post


Link to post
Share on other sites

Hey Steve,Doing good, thanks, hope same goes for you.There is currently no way of enabling DX10 Vsync through the Forceware, Nvidia and microsoft appreantly decided that its not needed.Unfortunately the only way to get Vsync, is if the application has that option in-game natively.What you could try, if you haven't already is to enable triple- buffering through the Forceware, that should help reduce tearing partly.Regards,

Share this post


Link to post
Share on other sites

Thanks again ...Well Nvidia and Microsoft were WRONG. I need VSync in DX-10! I think I will write a note on Phil Taylor's blog to that effect. I doubt if it will do any good. They are all busy with other things now.I think the only way to get the triple-buffers is if that is availible in-game natively, as well. I read this on my NHancer notes:"Another disadvantage [of VSync] is, that if the game doesn't use three buffers for rendering the scene (a so called triple buffer), the frame rate cannot fluctuate freely. Only integer fractions of the monitor's refresh rate (i.e. 1/1, 1/2, 1/3, 1/4, 1/5 etc.) are possible. In the case of the refresh rate of 60Hz, the only possible framerates would be 60fps, 30fps, 20fps, 15fps, 12fps..."this effect can avoided completely, if the game uses triple buffering. Unfortunately, the game itself has to request a triple buffer, there is no way of forcing them through the driver. ..."Still, most people prefer to play with VSync enabled, even without a triple buffer, because the movement of the images are much much smoother than without VSync. ..."Force OpenGL Triple-Buffer --Forces an OpenGL game to use a triple buffer, thereby eliminating the disadvantages of Vertical Synchronisation. This option has no effect for Direct3D games."So I assume that FSX does not "request a triple buffer" and if that is the case, then I cannot force it on.So disgusting. Ah well... at least I have all of the DX-10 hardware/Vista... so I can buy other DX-10 games I guess. I just wish I was interested in them. ;^)Have a great day!Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this