Sign in to follow this  
Guest

Help! Blurred Textures are back!

Recommended Posts

Helllo All:After many happy months using my Win98, PIII 450, 256MB RAM, GF3 Ti-500 system, blurred textures have returned.I'm using NVMax and have confirmed that my settings are the same as the ones that I have been using for months. I have examined the FS2002.CFG file, and cannot find anywhere that I would recognize where a setting has been corrupted. The textures immediately around the aircraft may display the highest level of texture quality, but at a very short distance they revert to medium textures.These are my current [TERRAIN] settings, within which are the usual suspects:TERRAIN_DEFAULT_RADIUS=2.500000TERRAIN_EXTENDED_RADIUS=4.000000TERRAIN_EXTENDED_LEVELS=4Additionally, here is a setting from the [GRAPHICS] section that seems to be important:TERRAIN_MAX_LOAD=1024All texture quality settngs for terrain and aircraft are maxed. Autogen is off, Scenery complexity normal, Mip Mapping, multi-texturing, tri-linear filtering enabled.Any thoughts?. It worked up until a few days back. I have not messed with the FS2002.CFG file until last night after the problem developed. Recent installs have been Justin Tyme's Beta3 Landclass and Mesh for the Pacific Northwest. I've removed both with no changes noted.Any thoughts? Thanks, Rick

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Can't help you on this, but can somebody tell me what these Config settings are doing?Jack

Share this post


Link to post
Share on other sites

Jack:As I understand them. These definitions are not mine, but do represent an approximation of what the settings appear to do:TERRAIN_DEFAULT_RADIUS= Controls the rendering of the highest quality to the lowest quality textures that you will see out to a distance of about 40 miles.TERRAIN_EXTENDED_RADIUS= Controls the rendering of textures from 40 miles out to a visible limit of about 70 miles.TERRAIN_EXTENDED_LEVELS= This is reported by many to be a Boolean value, while others set it to a maximum value of 4 in the belief that it helps to resolve the blurry textures seen closest to the aircraft's position by forcing the program to render the highest quality textures.TERRAIN_MAX_LOAD= Is set by the Options->Settngs->Display->Aircraft->Aircraft textures size slider, and is a multiple of 64. 1024 is the highest program setting, and refers to the largest texture file that will be loaded for aircraft appearance.Hope this helps. Use at your own risk. Usual disclaimers apply.RickP.S. Now back to my original question. What have I overlooked that is causing my blurred textures?

Share this post


Link to post
Share on other sites

Hi Rick, It's such a coincedence that this is happening to me too. With the hardware that I'm running I can only sumise that it FS2K. Im going to blow it off then do a complete reinstall. BTW are you using FS Assist?Ron CIntel P-4 1.8 Gig512MB PC2100 DDRAMMSI G-Force 4 128MB19" MonitorSB Live ValueForcefeedback StickIs it ever enough?

Share this post


Link to post
Share on other sites

Ron:I'm not using FS Assist, or any other type of 3rd party program to load textures or aircraft. I do all of that work manually.I'm considering restoring a previous registry to see if something in the registry itself was corrupted, leading to this problem. Other than that I'm stumped.It's obvious that the sim is not trying to load the highest definition textures by the fact that my frame rate has increased, the sim is smoother when the AI traffic load increases, or I am in areas with more intense Autogen. Textures in mountaineous areas appear to load at a higher level of definition than landclass in cities and towns. In all cases the highest level textures remain directly below the aircraft, but do not extend out. I may overwrite my seasonal textures to see if there is an issue there, though I doubt it.I'm also going to restore the default settings from NVmax, then trying retweaking from scratch. Perhaps there is something embedded in a setting that otherwise appears normal.Still trying.Rick

Share this post


Link to post
Share on other sites

To anyone who can help:The sim will render the highest quality textures within say 5nm of the aircraft in flight at 9,000 feet. Beyond that point the sim selects the medium quality textures.My settings are the same as before when the textures rendered properly. By that I mean that I'm not asking the processor to do so much that texture quality is suffering. The bottom line is that I cannot expand the radius around the aircraft where the high quality textures are rendered and retained, even with the settings to do so properly selected.Rick

Share this post


Link to post
Share on other sites

>Helllo All: >>After many happy months using my Win98, PIII 450, 256MB RAM, >GF3 Ti-500 system, blurred textures have returned. >>I'm using NVMax and have confirmed that my settings are the >same as the ones that I have been using for months. I have >examined the FS2002.CFG file, and cannot find anywhere that >I would recognize where a setting has been corrupted. The >textures immediately around the aircraft may display the >highest level of texture quality, but at a very short >distance they revert to medium textures. >>These are my current [TERRAIN] settings, within which are >the usual suspects: >>TERRAIN_DEFAULT_RADIUS=2.500000 >TERRAIN_EXTENDED_RADIUS=4.000000 >TERRAIN_EXTENDED_LEVELS=4 >>Additionally, here is a setting from the [GRAPHICS] section >that seems to be important: >>TERRAIN_MAX_LOAD=1024 >>All texture quality settngs for terrain and aircraft are >maxed. Autogen is off, Scenery complexity normal, Mip >Mapping, multi-texturing, tri-linear filtering enabled. >>Any thoughts?. It worked up until a few days back. I have >not messed with the FS2002.CFG file until last night after >the problem developed. Recent installs have been Justin >Tyme's Beta3 Landclass and Mesh for the Pacific Northwest. >I've removed both with no changes noted. >>Any thoughts? Thanks, Rick Hi,Your answer lies within your post as the "dynamic Blurrie" texture problem is a direct reflection of the power of a given cpu and memory sub-system to supply your video card with all of the display data, the more you ask Fs2k2 to do (as in added high rez mesh or setting the "mesh detail" slider to max etc the more you will encounter the dynamic blurries. since your machine is a bit low on power it would help if you turn your settings down, especialy the terrain detail, ground shadows, visability etc. and atleast set the TERRAIN_EXTENDED_LEVELS=4 back to =1 or =2.Take care

Share this post


Link to post
Share on other sites

Paul:Thanks for the reply. As I had previously mentioned the textures were fine until a few days ago. Now, only those textures directly below the aircraft are high resoulution. By the time I climb to 25,000 feet the view toward the distant horizon, out from 2 miles to 30, becomes a complete blurry mess, the worst by far that I have ever seen. The alterations to the FS2002.CFG file made no difference in the way the program was being rendered. I had installed DirectX 8.2 perhaps 5 weeks back, and it has worked like a champ. The 22.80 drivers for my Ti500 likewise have been superb.At my wits end I have backed up the important files and completely removed and reinstalled the program. I'm off now to replace the default files with the ones from before the uninstall. Then we'll see.Who out there has the pearl of wisdom on this one?Rick

Share this post


Link to post
Share on other sites

It's a long shot but do you have any new (or updated) programs running in the background that may be robbing vital CPU load?

Share this post


Link to post
Share on other sites

Rick,I'm sure you've done this but have you changed your fps slider? A different setting might help. I finally discovered what my system liked and left it there. Performance has been very consistent. I too have installed the landclass and pnw mesh. I noticed that in large cities the autogen and textures were taking far longer to generate. Close to the aircraft they were fine. Like Paul said, our systems are probably being taxed by all of it. Sorry if I'm not much help. Will ponder this. My settings are:Texture quality: HighTerrain mesh: 78Terrain size: HighAutogen: Extremely DenseScenery Complexity: Extremely DenseDynamic Scenery: UncheckedEffect Detail: HighMax. Visiblity: 70miToddK7 700384 SDRAMTNT2 32mbME

Share this post


Link to post
Share on other sites

Try this guys and let me know soonest.Is it FSUIPC ????I Rename this file to FSUIPCBak.dll and run you fs again. You still have fsuipc in the menu. But I didn't get the blurred textures. Maybe the blurred textures returned for us all cos we all got the latest fsuipc.dll which my current 1 is 2.94Try itwe gotta get to the bottom of this one

Share this post


Link to post
Share on other sites

"Who out there has the pearl of wisdom on this one?"No wisdom here. But I remember very well that another user reported exactly your problem, and he had also attached screenshots.After trying every suggestion thrown at him in this forum he finally solved it by reinstalling FS2002 from scratch. Actually, it is not as dramatic as it sounds :-)Stamatis

Share this post


Link to post
Share on other sites

First, Happy Thanksgiving to all who celebrate the holiday.Here's the layest on the texture problem.As a reminder I'm using a PIII 450 with 256 MB RAM, and a Leadtek GF3 Ti500. With frames locked at 11 the sim is reasonably smooth, and the rendering has been of a very high quality indeed, with the sharpest textures the program is designed to render visiblle out to 6-8 miles, and then a very gradual blending toward the horizon. Until...3 days a go I went from great scenery with sharp textures to a blurred mess. Airports, Airplanes, and Autogen were unaffected. Within 1-2 miles in flight the textures were sharp. Beyond that they went from medium to a mess. At altitude the horizon, 20-25 miles away, was an unrecognizable mass of blurry topographic outline.I checked every display setting within the program, all set correctly. Retweaked my Ti500 with NVMax, no joy. Changed time of day and location, same problem. Changed aircraft, same problem.In the FS2002.CFG the following Under TERRAIN had always been:TERRAIN_TEXTURE_SIZE=8 It's set by slider, and has remained maxed.The following settings are only altered by editing the FS2002.CFG file itself. I have changed the values in the past individually and collectively, but the changes did not affect the quality of the textures. These were my starting values:TERRAIN_DEFAULT_RADIUS=2.500000TERRAIN_EXTENDED_RADIUNS=4.00000TERRAIN_EXTENDED_LEVELS=1Repeatedly changing any of these values had no affect. All changes made to the FS2002.CFG file were done after exiting the program. I would save the changes and then restart Flight Sim. Most times I would restart the computer before launching Flight Sim, to ensure that information stored in RAM was not being used.With no improvement I next overwrote all of the texture files to ensure none were corrupt, no improvement. I removed the Scenery.DAT file from the FS2002 main folder and allowed the program to rewrite it. No change. As I was doing most of the test flying around Seattle, I removed the Pacific Northwest Mesh and Landclass files that I had recently installed, no change.Suspecting that it might be the latest FSUIPC, Ver 2.94 I removed it and reinstalled Version 2.93, which had worked just fine. The problem remained.So I reset the defaults in NVMax and uninstalled it from the computer. I checked my display driver, Detonator version 22.80, no problems. Tested DirectX V8.2, found no errors. With no where else to go, I created copies of the critical FS2002 files, and then removed the program, including locating and deleting all of the registry entries I could find. I then reinstalled the program. I intentionally allowed the program to create the FS2002.CFG file on its own so that I did not copy an error from prior to the uninstall into the new installation. Almost the same degree of blurriness returned. With no other thoughts I then went back to the:TERRAIN_DEFAULT_RADIUS=2.500000TERRAIN_EXTENDED_RADIUS=4.00000TERRAIN_EXTENDED_LEVELS=1Settings. I had no reason to believe that changing them would help, but had little else to go on. Bottom line, by adjusting the TERRAIN_EXTENDED_LEVELS= from 1 to 2 to 4 to 8 to 16, then finally to 32 I incrementally extended the high resolution textures out to where they had been before the problem appeared.Equally,Leaving TERRAIN_EXTENDED_LEVELS= at 1, and then adjusting the TERRAIN_DEFAULT_RADIUS= from 2.500000, to 5.00000, to 10.00000, then finally to 15.00000 accomplished much the same result. Adjusting TERRAIN_EXTENDED_LEVELS= seemed to work better. After extensively experimenting with the new settings, I changes them back to the default settings and the problem reappeared, confirming that my changes were working and the improvements were repeatable,As stated above changing these settings before reinstalling the program had no affect. After reinstallation they helped to solve the problem. I can't explain why that is true, though I have a theory.Would like to hear what others think. Rick

Share this post


Link to post
Share on other sites

So, as with the previous user that I referred to in message #12 above, re-installation is the way to go when something like this happens?Stamatis

Share this post


Link to post
Share on other sites

This has been a very nice thread indeed gentlemen. But after reading it (somewhat quickly), I noted that one of the oldest tricks in the book hadn't been addressed (if it was, then please accept my apologies). One idiosyncrasy within FS2K2 is it's uncanny ability to corrupt the config file (fs2002.cfg in your root folder). This can lead to all kinds of problems, including the gradual onset of blurry textures. Fortunately, the fix is simple. Just move your existing config file out of the root folder, then restart MSFS2K2. It will create a new .cfg file for you. Of course, you'll have to reset everything to where it was before, but usually this solves a variety of phantom problems that crop up from time to time. And best of all this saves you that lengthy reinstall, which for me would take the better part of one week. No muss, no fuss.Have fun flying :-)

Share this post


Link to post
Share on other sites

Rick,You Stated:"Bottom line, by adjusting the TERRAIN_EXTENDED_LEVELS= from 1 to 2 to 4 to 8 to 16, then finally to 32 I incrementally extended the high resolution textures out to where they had been before the problem appeared.Equally,Leaving TERRAIN_EXTENDED_LEVELS= at 1, and then adjusting the TERRAIN_DEFAULT_RADIUS= from 2.500000, to 5.00000, to 10.00000, then finally to 15.00000 accomplished much the same result." ***************************************************************You have somthing else going on here as TERRAIN_EXTENDED_LEVELS= greater than =4 (or even greater than 3 for that matter) have no (and little >3) effect what so ever, Further TERRAIN_DEFAULT_RADIUS= values greater than 9.999999 have no effect what so ever.You have some other issues going on and as recommended you should delete your Fs2k2.cfg and restart FS to let it rebuild it.BTW, what setting do have in the FS2k2.cfg for the following?:{TERRAIN}TERRAIN_ERROR_FACTOR=?TERRAIN_TEXTURE_SIZE_EXP=?TERRAIN_EXTENDED_TEXTURES=?

Share this post


Link to post
Share on other sites

Paul:In the terrain section, these are the current settings:[TERRAIN]TERRAIN_ERROR_FACTOR=7.650000TERRAIN_MAX_VERTEX_LEVEL=19TERRAIN_TEXTURE_SIZE_EXP=8TERRAIN_AUTOGEN_DENSITY=0TERRAIN_USE_GRADIENT_MAP=1TERRAIN_EXTENDED_TEXTURES=1TERRAIN_DEFAULT_RADIUS=2.500000TERRAIN_EXTENDED_RADIUS=4.000000TERRAIN_EXTENDED_LEVELS=32As I explained in my previous post, the only value I changed was the TERRAIN_EXTENDED_LEVELS= setting. Starting with 1, I increased the values as described. Each time I changed the value by one increment, then saved the FS2002.CFG file and restarted Flight Sim. I remained in the same location, orbiting MT Rainier, and observed the textures for clarity. As the values were from 1 to 2/4/8/16/32 the highest quality textures that were uniformly rendered increased in distances, starting approximately 1-2 miles from the aircraft while 5,000 feet above the surface at a setting of 1, and ending up with the same high quality resolution and uniformity out to 9-10 miles at a setting of 32.I've read elsewhere that settings beyond 4 do not affect the sim, and at first stopped there because of what I had read. Determined to find a solution to the blurred textures, I pressed on, and achieved the results described above.On a separate note, on the issue of regenerating the FS2002.CFG file:After re-install as previously described I allowed FS2002 to generate a new FS2002.CFG file. Next I copied the settings for the keyboard and joystick from the pre uninstall CFG file into the newly created file. Then I went back into the program and set all of the aircraft and display settings from within the program itself, so as to avoid transcribing any previous problem.With Thanksgiving Dinner over, its time for the second test flight since success to see if my efforts have withstood the test of time, in this case 24 hours with the computer shut off.We'll see. Rick

Share this post


Link to post
Share on other sites

TERRAIN_EXTENDED_LEVELS=1did it for me.I deleted my fs2002.cfg. Ran fs2002 set my settings before flying.Then exit the sim straight away once on the ground. I saved my fs2002.cfg and now I copy this .cfg file into flightsim folder before running it every time now and no blurred textures.Hope it work for youGraham

Share this post


Link to post
Share on other sites

Couple other things:1. Have you defragged in a while. I get noticeable increases in performance after doing this tedius but important maintenance. 2. How long has your computer been on? I get memory leaks if I leave the machine on for a long time. I also think that there is some degradation over time caused by some unknown corruption because I know I am not getting the samer performance today as I was getting several months ago. I may try the config fix, but am a bit intimidated with button assignments etc. Colin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this