Sign in to follow this  
Guest

FS2002 freezing in WindowsXP - Help please!

Recommended Posts

After having not been satisfied with Windows ME I decided to switch over to Windows XP Pro. I also installed a new soundcard (Soundblaster Audigy 2 Platinum). Everything works fine & stable except for my FS2002: It freezes instantly, sometimes already in the startup-screen, sometimes during the setup of a new flight, but always before I even can start the engines!I made a "clean" XP-install, no update!First, I thought the reason for my problems might be my old airplanes and sceneries (I simply copied them into my new installation folders). But even a complete deletion of my FS2002 folder, followed by a new installation, did not solve the problem.Does anybody have an idea? I don't know what to do... I upgraded my system only for FS2002, and know this is the only program that does not work any more :-(This is my system:Athlon 2200+Enmic 8TAX4+ Mainboard (with new VIA 4-in-1 driver)512 MB DDR-RAM80 GB WDAsus V8440 GeForce 4 Ti 4400 (with new Nvidia-driver)Soundblaster Audigy 2 PlatinumWindows XP ProDirectX 8.1Greetings from Germany,Timo

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I haven't any problem in my Win XP environment, but usuallywhen it comes to problem it might depend on hardware suchas the sound card or drivers.You might try the following:Run the program "dxdiag" (you can type that into the run-box).Open the sound part in the started window. Turn off the hardwareacceleration on the sound card, and then try to run FS2002once again.Best regards Bj

Share this post


Link to post
Share on other sites

Did you update the drivers for your controller chips, i.e., Via, Intel, SiS, Amd, etc? Did you update the drivers for your sound and graphics adapter?What sound card/on-board did you use before the upgrade? If on-board, did you disable it in BIOS before you installed the new sound. Are the sound and graphics adapter using the same IRQs. If so, try moving the sound away from the graphics adapter.

Share this post


Link to post
Share on other sites

What speed is your AGP running at? 8X? If yes, change it to 4X.Cheers

Share this post


Link to post
Share on other sites

Timo,Before you try anything else just cut and paste your 2002 config file to the desktop and then reboot FS2002. Your config file is probably set up for the old operating system. If this doesn't work you can always replace the old config file on your desktop.Best regards,Jan

Share this post


Link to post
Share on other sites

Dear all,first of all thank you very much for your suggestions. Unfortunately I still didn't manage to solve the problem:- I reduced and even disabled sound hardware acceleration- the onboard sound has always been disabled in BIOS- all drivers are actual- there can't be any old sceneries or planes 'cause it's a fresh installation (both WinXP and FS2002)- AGP is set to 4x- The cards use different IRQs- The install-CDs are okay, I used the same with WinMEIt must have something to do with my graphics card's hardware acceleration: If I turn it off in FS2002, it does not freeze any more. But who wants to fly FS2002 without hardware accelerated graphics???I just won't believe that such an expensive card like the Asus V8440 GeForce4 Ti 4400 is not compatible with WinXP Pro and FS2002!!???Is the Win XP Service Pack 1 (or even 2) necessary to download, if I use Win XP Professional? Will it ease my pain? ;-)Kind regards,Timo

Share this post


Link to post
Share on other sites

Timo:Try at least the 2 following things:1. Experiment with video card drivers...I have noticed some drivers cause probs..eventually you will tweak the system.2. Set back your screeen resoultions and FS res. If they are all at or near max, this may cause a strain.I run my FS2002Pro with all sliders max..XPPro NV64Mg card 1600 resFull screen.P-4. 1.4256mgs Ram.Sim works perfect.However..with this setup, I have probs with other games..Sttur, lockups etc.Tweakin'Good Luck!MMWZA

Share this post


Link to post
Share on other sites

Dear Simmers,Since I reduced AGP speed in BIOS to 2x the sim does not freeze any more! I also tried older versions of the Nvidia drivers (V29.x), but that did not make a difference.Although this is some kind of solution, I'm not so happy with it as it reduces 3D performance in any application.I don't think it's a problem with the graphics driver, I believe it has something to do with my hardware. But on the other hand I won't believe that my system configuration (Enmic board, Asus graphics card, Terratec soundblaster...) is responsible for it - seems to be a compatible combination.

Share this post


Link to post
Share on other sites

Twinner, good to see you kind of got you problem fixed, but if turning down the AGP speed helped, I suspect it's some kind of problem (incompatibility) between the AGP slot and video card.Do you know which chip set's you have on the video card and mother board? Have you looked for new drivers or issues at the manufacture sits? These kind of problems can drive you crazy, as it did for me. Back in FS98 days, I could not run the sim in 4X AGP. My system just didn't like it. I do find it strange however, that you can't run in 4X in this day and age.Good luck and cheers for now

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this