Jump to content

Sign in to follow this  
Ray Proudfoot

ASX problem - SimConnect not able to be loaded

Recommended Posts

Hi chaps,I'm getting the following error when running ASX from a laptop trying to connect to FSX on a desktop PC...SimConnect (SP1 version) was not able to be loaded... this is required for operation with FSX....Here's what I've tried so far...1. Uninstalled SP1 and reinstalled it.2. Deleted the folder ending in the name 429211e9 containing simconnect.dll in c:windowsWinSxS.3. Run the repair utility on the FSX DVD.4. Deinstalled and reinstalled ASX.I'm just about at my wits end. I know the problem is related to simconnect and not AS but it doesn't make it any easier to take. :-(Additionally I'm now getting problems with my GoFlight software when FSX starts and it seems connected to deleting that WinSxS folder.I've created a simconnect log (thanks Pete Dowson for that tip) and can attach it if you feel it might help resolve the problem.One question I hope doesn't sound silly. Does WideFS have to be running before I start ASX and should FSX already be running? Okay, 2 questions :-)Appreciate any help you can provide.


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

I've just read the documentation within ASX relating to networks and it seems I'm missing a file - SimConnect.xml in ApplicationDataMicrosoftFSXIt's necessary to download the SDK SP1A file from www.fsinsider.com which I'm doing at present.If installing this resolves the problem I'll be a relieved man.Computers are getting too complicated!:(


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

Okay, all sorted. I followed the instructions in the ASX program and I've now got ASX talking to my FSX PC.Hope this may help others :-)


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

I spoke too soon. ASX is now connected to my FSX PC but the weather isn't being updated.In the ASX log window there are multiple messages...Problem adding a virtual gap station: Object reference not set to an instance of an object (Error) Source=I have 6 of these entries so far after 5 minutes of running. Eventually Task Manager reports ASX is not running. Any clues please?


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

All I did was use FSUIPC to clear the weather, restarted ASX and it's now updating the weather. ????However, I'm getting lots of Exception received: 14 messages. Can you please explain what these are?At least I'm now seeing the airport shown in the Report and Map screens so progress is being made although it feels like teeth being pulled :-(Really nice looking product. Just flippin' simconnect which seems to be the culprit for all my woes.


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

After some searching of the forum I've now resolved the multiple Rxception received messages. :-)All does now appear to be well. ASX is run first and once the process is complete FSX is started. That bit takes some readjustment after FS9/AS6.5 but despite being 56 I eventually got there :-)All I have to sort out now are my GoFlight modules. Since installing simconnect the executable to run them fails miserably. Unfortunately the GoFlight team don't support their forum so individual questions have to be posted to them. Hopefully one of them will know the cure.


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

Just wanted to give some feedback to the HiFi team...ASX looks absolutely brilliant. Well done to your graphical designer Tim Fuchs.On the Settings page there doesn't appear to be an option to turn off Tooltips. Once users are familiar with the product tooltips become redundant.I can't find anything about activating the voices or even which one to select. The status window shows 3 have been activated but that seems to be the only mention.Finally and perhaps the most important... I struggled to work out how to install on a network PC and eventually found the instructions on the main documentation link in the program. It would have helped to have a readme with the important bits in.Once I get my GoFlight problem sorted I hope to enjoy many flights with ASX. Well done to all the team!:-beerchug


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...