Archived

This topic is now archived and is closed to further replies.

Jockos

Sound Distortion FSX

Recommended Posts

Folks, I have had both FS9 and FSX running fine on my rig. Smooth running and acceptable frame rates.OK the problem now:- On booting into FSX at the splash screen when 'THE' music starts, the sound is distorted. Some 'crackling' and hesitation in the music sounds. When the defaults come up and you begin to select an aicraft the distortion continues. With the aircraft selected and engine running (music has stopped)the distortion continues sparodically. On applying throttle distortion increases with stutters occuring in sync with the sound issues.I have similar issues in FS9 but not to the same extent.What I have done:-1. Uninstalled and reinstalled the latest drivers for Realtek ALC 883 for the onboard sound.2. I completely removed both drivers and card for SB X-fi Extreame Audio. Creative are having problems with these cards and 4Gb RAM. I did not, but have removed it from the equation. I previously ran on the Realtek successfully before the promlem arose.3. Defraged all my drives. I am running both verions of FS on one dedicated drive.4. At some stage, I am not sure when (possibly after removing the old Realtek and Creative drivers) Some yellow(!)'s appeared under 'Sound video and Game Controllers' in Device Manager. They were against the audio and video codecs that are installed with XP. Hopefully, I have restored them correctly.I guess some obvious questions:- 1. Is sound OK everywhere else? Well I have played Windows Media Player in audio for ages trying to induce the issue. It has only happened once, with similar distortion as in FSX. I have been unable to induce this again, so a bit uncertain here.2. Are other games affected? Unfortunately I only 'play' FS!3. Are all the audio and video codecs in place? Not sure what FS uses here to check this out.As you can gather, I am assuming (pretty dangerous!!) that I do have a sound problem. Maybe it is something else and that is why I have come to you learned folks on this forum. Trust you can assist.My system specs:-Mobo GB GA-965P-DS4Intel E66004GB RAMVideo Card 7900GTOS XP Home SP2RegardsJock McIntyre (YMML)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

My wife had that same problem with her rig...She is not a Flight Simmer,but plays all *The Sims* stuff....I mean the exact same problem..And it came and went too,making it hard to find the prob..We took it back to BestBuy....They said Vid card,sound card,as they ran tests on it,and it did have a leaking captisor on the Audigy card...We replaced both.....Got home ...Same problem.....Took it back,they said it must be the MoBo.....So shipped to HP.....Replaced MoBo........Same problemTook it back,reshipped to HP..said MoBo replacement was faulty...out of stock..Two weeks later it was returned,and they also replaced something with the sound located in the front case up by the USB connections( forget what it was)Fixed...Finally.....Time without rig.....7 weeks total....Solution/cost to fix...LOTSNew laptop the first time it shipped to HP,as wife needed a puter,and we wanted a laptop for traveling....1,800 with extended warrenty...First trip to bestBut....1 sound card.. 1 Vid card...Total cost about 375 bucksFed up with off the shelf junk......Purchased two Digital Storm high end rigs (one each. cost for both...6,5000 bucksSo I say to you...Sorry to hear that...I would pull the sound card and look for ovbious singns/smells of failure....Vid card too....After that...try onboard sound as a test.....Good luck to ya.....

Share this post


Link to post
Share on other sites

Yep, same deal with a P5K-e/Vista 64. The system was fine for 6 months at a 400Mhz FSB/3.6Ghz Q6600 and 4Gs of DDR800 at 800Mhz . . . , then this started. I could hear distortion in Windows boot chime. Media player mp3s were distorted and FS was unusable. The FSX intro music was distorted. The game ran at 1/2 speed with distorted audio and was a stuttery, visual mess. If I uninstalled the audio driver, then rebooted (or in-out of "Sleep"), the audio driver would reinstall. That fixed it . . . 'til the next boot. It was getting worse. Sometimes it took 2-3 "naps" to get a clean audio driver reinstall. I tried 3 audio driver versions for my onboard sound. No change at all. I deactivated the onboard sound and installed an add-in sound card. No change at all. I rma'd the mobo (Asus was mystified as usual). No change at all. I X'd-out then reformatted my HD and started from scratch. No change at all. Since the system was O/Ced to 400Mhz, I finally turned down the FSB to 380. That worked. The problem went away . . . and could be duplicated. Above 380, I got audio distortion. Below, all was OK. However I missed my clock. Just recently I traded in a 9800GTX for an 8800GT Vcard and reinstalled the latest Nvidia Vdriver (what ever it is right now). For grins, I reset my FSB to 400. The audio problem stayed Gone. Was it the Video driver? Really don't know, but there's a couple of thing to try.

Share this post


Link to post
Share on other sites

Guys, Thank you for your replies.I updated my vid driver to 84.21, the current ver reccommended by Gigabyte for the 7900GT. Unfortunately, no change to the sound quality!!!!The only thing I can think of now is to swap out the 7900GT with anything else to disprove or otherwise, the video card. I may be able to do that next week. I could aso disable the onboard Realtek and reinstall the Creative X-Fi Extreame Audio cardAnyone got any other ideas???RegardsJock McIntyre (YMML)

Share this post


Link to post
Share on other sites

You would not think thatan aging/failing vid card would cause sound problems...But it does.........Don't know why...But I've been there...Seen That....LOLHope your swap proves it.....

Share this post


Link to post
Share on other sites

Men, Thanks again for your responses. Have d/loaded the latest driver and will install.I have made a startling discovery!!! 99% of the time I use PMDG model/s in both FS9 and FSX. Just of late, I have had the need to test some sofware using the default models. This is when I realised the sound issue. Last night I flew the PMDG 737 (in FS9) for an hour without one sound distortion. I am assuming the same in FSX after you get past the splash screen/intro music scenario and select PMDG. So, possibly I have had this issue for some time and not realised it. I have not used FSX recently for PMDG so haven't heard the music stuff on boot up. I guess this means that a different set of sound files are being used with the PMDG add-on, over the default set. Intrigued that both FS versions are affected. Well, there is still something wrong and I would like to fix. It sort of takes it away from being a video card problem and back to sound, perhaps. Have I got all the audio codecs for MSF?? How do I know that?? The thought of uninstalling/reinstalling both FS versions would induce heavy drinking and I would live with the problem given that I use the default aircraft rarely.Still like to fix. I will go through the video card and sound 'swaps' to see what I come up with.RegardsJock McIntyre (YMML)

Share this post


Link to post
Share on other sites

If it's the same sound problem, it will show up with mp3s in media center. The gyro-video effects will stutter and the audio will be choppy. PMDG is pretty much still a nogo in FSX. As the airplane gets closer to the ground, FPS performance tanks . . . even with eyecandy sliders virtually off. I'm a 99% PMDG 744 flier and I'm back to FS9 for any serious flights. 15, even 20 FPS simply does not provide adequate feel to seriously handfly a Cat3b approach at 1/8 mile visibility. The airplane's gotta go Precisely where I want. This kind of flying is Entirely different from a GEX enHanced session of sightseeing in the Barron. That's fun too and I'm constantly amazed at the performance and visuals that are available with GEX/UTX/FSG and the default airplanes. However it's also nice to be able to "get serious" on Vatsim with a fully FMC capable airplane. FSX simply cannot support the PMDG airplane at that level. Also SB is still not ready for FSX and FSINN is a bust with PMDG.Just for fun I fired up FSX and flew the 744X on a VFR approach to JFK's 13R with normal sliders for the default airplanes (all sliders full, x-water and ~ 10% traffic). We staggered down final at 10-15 FPS, but it was sooo cool to see 3D buildings scooting by out the window. Too bad really. My guess is 2 more years 'til we get this at 30+ FPS.

Share this post


Link to post
Share on other sites