Sign in to follow this  
Guest Edwin

Trim when landing

Recommended Posts

Hi,I've been having trouble landing the PSS A340-300. I normally wait for the bus to intercept the LOC and G/S and then I would disengage the A/P and the A/THR to manually bring the aircraft to the ground. This has generally worked well for me with the PSS A330-300 but on the A340-300, the trim suddenly starts "flopping" after I disengage the AP. When I say flopping, I mean that the elevator trim will jump from UP to DOWN and then back again repeatedly in a matter of seconds. Needless to say, with this kind of rapid change in pitch, I can never land properly.I thought it could be wake turbulence or windshear but it happens even with no winds or no other aircraft around. Any ideas on what's happening here?Many thanks!EdwinFS2004Intel Pentium 4 3.4GHzCorsair TWINX1024-4000PROASUS P4C800-E DeluxeATI Radeon 9800 Pro (Catalyst 4.3)Creative Labs Sound Blaster Audigy 2 ZS2x Western Digital Raptor 360GDPioneer DVD-120S DVD-ROM driveLite-On 52/32/52 CD-RW driveZalman ZM400A-APF PSUCorsair Hydrocool HC200Cooler Master ATC-101 caseMitsubishi Diamond Pro 2060U 22" CRTOptiquest V75 17" CRTKlipsch Promedia Ultra 5.1FSUIPC 3.201 registeredActivesky 2004 MR1 (build 90)Windows XP Professional SP1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have the Same problem it is soo annoying especially after a long flight !!!tj

Share this post


Link to post
Share on other sites

Did you try to use Bob Scott's FDE's? Check this Forum for his latest version 1.2H and you'll have proper landings.Regards,Sam

Share this post


Link to post
Share on other sites
Sign in to follow this