Sign in to follow this  
Guest CocoLoco

Switching off AI collision avoidance

Recommended Posts

I've been working on writing a small application that will automajically put more service vehicles at an airport such that when you request fuel, the other vehicles will trundle up as well. After spending a while wondering why my newly spawned service vehicles weren't working properly (they would happily follow my waypoints and head to any other object/aircraft that I asked them to, but not my own aircraft), I realised that AI objects take care to avoid the user aircraft. Given that I want them to move up to the right parts of the aircraft (and not keep a respectful 50m distance), this careful behaviour on their part is a bit annoying.Bar actually taking manual control of the objects, does anyone know if it is possible to disable collision avoidance for ai objects versus the user aircraft. BTW, the problem is not actually avoiding a collision, it's that they won't go anywhere near my aircraft.I've seen other AI flatbed trucks at an airport drive straight through my aircraft whilst others have taken care to avoid it, so I am thinking it should be possible but despite hunting around, I haven't had much luck.Any help would be gratefully appreciated...David / CocoLocoP.S. The original aim of this was to get a Stairway vehicle to drive up to the exit if a Jetway was not available. This is not much use if you have to leap 50m to get on the stairway :(.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this