Sign in to follow this  
Guest cragmont42k4

NAV n RADIO BLACKOUT

Recommended Posts

Iv'e juet sterted encountering the strangest thing...After taking off, about five to ten minutes into theflight, the autopilot display, the primary instrumentsand the radio (numerical displays) all go blank. Autopilot,speed indicators, nav tuning are all inoperable. This occursin all panels right across the board. The only exceptionsare the Level-D and PMDG panels. These however start navtuning in increments of 25. What the HECK.If anyone might be able to help in any way i would be very greatful. THANX

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Is your battery going dead? Have you turned on the Generator Switch? R-

Share this post


Link to post
Share on other sites

FS dead battery bug is well documented.one proven work-around -load FS default aircraft (say the cessna) before loading a more 'advanced' addon. confirm that the default aircraft has the avionics and battery switches in the on positions. keep the FS default aircraft loaded for 30 or so seconds to 'settle' FS's 'state.'--

Share this post


Link to post
Share on other sites

Battery Problem?Whooda Thunk!I made the Skyhawk sitting ther withBatt n Avionics ON my default flight.For extra measure I opened up my FSUIPCdialog and checked off the unlimitedbattery life feature.PROBLEM SOLVEDThankyou ever so much for your help.Now all is well in Simland.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this