Sign in to follow this  
alghotee

FS9 slows down in the background

Recommended Posts

I have this problem. First, it seemed to me that i fly somewhat slow. Doing IVAO Long Haul tour i noticed that other planes flying the same leg are moving faster on the map, they even overtake me enroute with lower mach speeds. Just now i measured some things and found out that after flying for 60 minutes at 450 ground speed i only covered 270nm of the route on the map. Its only so if FS is being run in the background. When FS is opened on the screen, the speed is normal. It appears that simulation slows down considerably when i switch to desktop during the flight (Alt+Tab), somehow it works very slow in the background. Any idea how to correct that? I use laptop, Core 2 Duo 5270 1.4Ghz, 2 GB RAM, Nvidia 8600 GS 512 mb. When i switch to desktop with FS running at the background, Core 1 load drops from 90-100% to just 5-10%, almost like its idle. And yes, i have 'pause on task switch' unchecked. Any thoughts?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Here some more info:I tryed couple of things and found out, that when in windowed mode (alt+enter) and in the background NOT MINIMIZED, the speed is normal, and CPU load is normal also. It only slows down if FS is minimized, and CPU load drops to under 10%. So how does minimizing the FS window affect it like this?

Share this post


Link to post
Share on other sites

Sounds strangeYou said you were using a laptop, is there something in your power options regarding processor allocations ?Just a thought Mark

Share this post


Link to post
Share on other sites

Doesn't look so, I tried to turn off every power management option there is (while powered from the adapter), nothing changes the situation.

Share this post


Link to post
Share on other sites

I presume once you minimize fs9 you are still using your laptop for other applications .Are they also cpu intensive .It could be the way your laptop allocates the cpu Ie The programe you are using as opposed to the one in the background .Mark

Share this post


Link to post
Share on other sites

The CPU load drops immediately to under 10% once FS is minimized, even if no other programs being run. Thats weird :(

Share this post


Link to post
Share on other sites

Weird indeedOkay ive just run fs9 in windowed mode running on one core onlyPMDG 747 ten miles from egll in cloudy conditions the cpu usage is 58%Once minimized it drops to 30 40% and memory usage remains the same Also when minimized I can here the flightsim running but when i try to start another program FS9 pauses for me .How do you get it to run without pausing Let me know and i will try a flight on my lappy and pc together with one minimized and see if the outcome is the same as yoursMarkEdit pause on task unchecked still dont want to play!!!!

Share this post


Link to post
Share on other sites

>Also when minimized I can here the flightsim running but when>i try to start another program FS9 pauses for me .>How do you get it to run without pausing >Let me know and i will try a flight on my lappy and pc>together with one minimized and see if the outcome is the same>as yours>Mark>Edit pause on task unchecked still dont want to play!!!!Hmm, my FS doesn't pause if minimized. I also don't have FS sound if it is minimized, sounds come back if i make FS window active. It looks like FS does what ever it wants on every individual system :)

Share this post


Link to post
Share on other sites

Well i cured the pause issue with a good old fashioned reboot ,go figure!Now it only pauses as i switch tasks then continues to run but that alone would not explain away the time loss you are experiencing .I have to admit im curious now ,so tomorrow im going to send a couple of default 747's off on an identical 4 hour trip , minimize one and see what the outcome is .It dos'nt solve your problem but at least you will know that it either does or does not happen to someone elseMark

Share this post


Link to post
Share on other sites

Well i sent two default 747s off to KJFK from EGLL,one on my pc, the other on my laptopNothing running on either apart from fs9(obviously)I put them both on autopilot and minimized the laptop flight Checked back after 4 hours and the @&%$"%* laptop had crashed!!!The only thing i learnt today is dont buy a sony vaio!!!!Im going to have another go , though it will have to wait untill the weekend .Work gets in the way of life sometimes !Hopefully i will have something to post saturday evening (GMT)Mark

Share this post


Link to post
Share on other sites

I finally found what the problem was. Before, I tryed to turn off every power management software there is, but didn't check the BIOS. There is another CPU power saving option in the BIOS, i turned it off and now problem is gone :) It looks like it was reducing CPU power on inactive (minimized) applications. Thanks everyone for trying to help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this