Sign in to follow this  
Guest cbuchner1

Healing the Blurries in FSX SP1

Recommended Posts

I found no cure for HIV yet, but one for the Blurries in FSX SP1Increased PerfBucket by factor 10, also set a pretty high fiberframe time fraction value.In the [ Main ] sectionPerfBucket=50FIBER_FRAME_TIME_FRACTION=1.20I also lock my frame rate to 20 (it isn't actually reached, I getclose to 15 fps).The outcome is: TileProxy munches a constant 8-15% of my CPU timeand does a good job keeping up with texture loads.And I am also running the proxyUser.exe process in Realtime prioritywith affinity locked to the 2nd core ( can be set manually in Task Manager or by modifying the load.bat script inside TileProxy folder.In Beta3 there is a comment inside load.bat to show you how to dothis. Edit the file with Notepad. )I am still undecided what AffinityMask in the [ JobScheduler ] sectionis best. 3 (meaning both cores) or 2 (meaning only the second core).Note that FSX currently munches 100% CPU time on both my cores when Ifly. That is why it is important that TileProxy is run at a higher priority (RealTime in my case).UPDATE:Under [ Terrain ] I have set an insanely high timeout for texture jobs, as to allow for any required loading times. 1000 frames is highenough, isn't it? ;)SWAP_WAIT_TIMEOUT=1000

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

SP1 or is it particular to X-core? And if the former, is there a notable improvement with SP1 or not on single-core machines?

Share this post


Link to post
Share on other sites

Tried the settings that were appropriate to my single cpu machine. Started at Tangri-La near Moab and was optimistic as TP updated a few sets of tiles but then no more updates even after flying around quite a bit. So, the scenery remained somewhat blurry with no higher res updates requested by the sim.locked at 20 fpsPerfBucket=50FIBER_FRAME_TIME_FRACTION=1.20SWAP_WAIT_TIMEOUT=1000

Share this post


Link to post
Share on other sites

Have tried your suggestions but on my single core rig everything starts fine but fairly quickly drops back to blurring. Have also tried fiddling with priority of ProxyUser.exe in the Windows Task Manager to no avail. Fiddling with scenery setting like mesh resolution and LOD radius only seems to affect load times. Larger FIBER_FRAME_TIME_FRACTION settings only seem to increase stutters. TP is loading textures as I enter new areas, but rarely do I get full resolution.Most reliable way to get texture is reload scenery assigned to a yoke button, but means an aweful lot of waiting!Can't get Zonealarm firewall to behave with TP - FSX stalls at about 33% loading and crashes. Switching to Windows Firewall for FSX sessions with TP works fine for me though.Christian you're still a genius. Haven't had a reason to re-explore the Flight Sim world properly since Fly! Who cares if I spend 30% my time in the air refreshing the scenery - at least I can explore my home city and surrounds properly!Fingers crossed you and perhaps Micro$oft find a way to get this running well, because its changed everything. RobAMD64 4000+, 2gb, FSX SP1, TP Beta 3

Share this post


Link to post
Share on other sites

I tried all of the suggestions but I still get blurry textures on my dual core. I think it might have been a tad better than before but hard to say. I usually fly for 5-10 minutes or so and then pause the sim to give it time to load the high res textures. Most of the time, it will eventually load them all and then I can fly for a ways with nice textures. Sometimes, and this seems to occur more often the longer I fly, it just won't load the higher res textures at all.This is a really neat program though. Keep up the good work. As Howard Hughes once said, "This is the way of the future."

Share this post


Link to post
Share on other sites

I did another test this morning by loading my previous saved flight and then flying a short distance away where I then saved a new flight. I exited the sim and unloaded TP. Then I started TP again followed by the sim. I loaded the new flight a short distance away and TP furiously downloaded textures. Hi res imagery appeared in my new location where it was blurry before. I flew for a bit and no more downloads occurred. The high res area remained as I flew around but no new imagery was downloaded and all other areas remained blurry. I am sure I could repeat this process and get hi res imagery at each new location but if I try to fly away from the start point no more updates occur. I hope this helps.

Share this post


Link to post
Share on other sites

I seem to have had more success in maintaining sharp textures and loading new ones by increasing my LOD in the sim from the small setting to medium. Logically, in my mind, I didn't think this would help but it did. Let's see if the results I saw last night persist today.

Share this post


Link to post
Share on other sites

>I have found that also. I keep my Lod at the maximum-it takes>a long time to load but the difference in sharpness is>substantial.>http://mywebpages.comcast.net/geofa/pages/rxp-pilot.jpgThanks. I will crank mine up to the max when I start my first session today. I have not looked forward to flight simulator sessions this much since I have been using sims which goes back to the old Bruce Artwick days.

Share this post


Link to post
Share on other sites

I find that maximum LOD gives me almost seamless performance too. Takes a while longerto load but well worth the wait.

Share this post


Link to post
Share on other sites

Same here ,takes takes about 4 minutes after clicking Fly now,but the wait is worth it, mid and far distance is much clearer, and when FSX updates higher LOD tiles as I fly It It redraws a much larger area around me in 1m textures compared with a low LOD setting.Looking at the great Canary Island shots earlier, I thought I would try Tenerife, tile proxy just gets better and better here's one pic from from above Puerto de la cruz the unique colours and structure of this beautiful Island came flooding back never been back there for 20 years until yesterday:) ... its uncanny.Lost for wordsJohnhttp://forums.avsim.net/user_files/172043.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this