Archived

This topic is now archived and is closed to further replies.

Guest terasz

Granular picture

Recommended Posts

I've got a problem, could you help me?Around the plane the picture is granular. not everywhere, because landscapes in the far away are clear.what should I change to solve it?I attached a JPG to see exactly what's it.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Have you added (or let the TP setup add) the MipBias entry to your FSX.cfg, and do you have an ATI card? If so, remove that entry.

Share this post


Link to post
Share on other sites

I have nVidia 7600GT, but I tried, and it works!Thanx for help me!(by the way what is "mipbias" is all about?)

Share this post


Link to post
Share on other sites

A polygon with a given (virtual) size covers less and less (real) pixels on the screen the further it is away from the camera (i.e. your virtual eye). That means the graphics card has to compensate by scaling the texture it is to apply to this polygon, but that only works well to a certain extent. For that reason, every texture exists at a couple of lower resolutions (i.e. smaller sizes), called mip maps, in addition to the nominal resolution. That way, the graphics card can always use a texture size that fits the polygon relatively closely, given its size on screen, by switching between the different mip map levels at some optimum distance as the polygon moves closer or further away. The MipBias setting adjusts this optimum distance. I think the default is 4, and higher numbers mean higher resolution mip maps will be displayed further out. Unfortunately, this often results in texture flickering.That being said, since you have an nVidia card, try setting 'Negative LOD Bias' to 'Clamp' in the nVidia Control Panel. That is reported to considerably reduce texture flickering.

Share this post


Link to post
Share on other sites