Archived

This topic is now archived and is closed to further replies.

Recommended Posts

Hi,I currently use 6.5 with fs9 and am soon going to install fsx.My question is since i do not own asx,when i upgrade will the version work with just fs9 or both.Sorry if i missed this in other posts.thanks,tony.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Jim,thanks that is great news,soon as christmas is over with i`m dusting off the credit card.Tony.

Share this post


Link to post
Share on other sites