Archived

This topic is now archived and is closed to further replies.

Guest armand

Ch Products Yoke

Recommended Posts

Here is my configuration:Windows Vista 32 bits FSX Flightsim yoke LE USB connection Driver CHproducts V30 Vista onlyMy problem: FSX does not keep my calibration. When I close the game or make another flight the calibration has to be done over again. I have even lost my calibration in the middle of a flight. Is there a way of ensuring that my calibration will be memorized and kept once and for all?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Here is my configuration:Windows Vista 32 bits FSX Flightsim yoke LE USB connection Driver CHproducts V30 Vista onlyMy problem: FSX does not keep my calibration. When I close the game or make another flight the calibration has to be done over again. I have even lost my calibration in the middle of a flight. Is there a way of ensuring that my calibration will be memorized and kept once and for all?
I can try to help :) Take a shot in the dark anyways :)You say it won't hold calibration 'in FSX" , do you mean it loses the assignments as well as your overall settings inside the FSX controller settings window? If you installed to the default directory, ie; c:/program files/micro.. etc, Vista has a bad habit of not allowing things to be written to the program files directory. 3 ways to cure it.1: Disable UAC, this stands for user account control. I don't recommmend it as this is a vista security feature. But you can disable it, try FSX and see if that solves your problem, at least you'll know the cause.2: THis is what I do, I install FSX to some other directory besides C:/program files..such as C:/Microsoft Games/Flight Simulator or some such thing. I actually install to another partition entirely.3: If re-installing is not an option, you can take ownership of the Microsoft Games folder inside Program Files. Navigate to the folder "Microsoft Games" , right click on it and click properties, then slect the security tab. Look in the list of users below, find your user name, and check off allow on all the options. Then click OK. It will go through a rather long process of going through every file in the folder and assigning all rights to every file there. When it completes, restart your pc and try your controller settings again.This is just a shot in the dark but I was having a similar issue back when I first got Vista and it cured it for me. It could also be a hardware. OS or driver problem. Or a buggy install if FSX. But this is something to try.Good luck, Larry

Share this post


Link to post
Share on other sites
I can try to help :) Take a shot in the dark anyways :)You say it won't hold calibration 'in FSX" , do you mean it loses the assignments as well as your overall settings inside the FSX controller settings window? If you installed to the default directory, ie; c:/program files/micro.. etc, Vista has a bad habit of not allowing things to be written to the program files directory. 3 ways to cure it.1: Disable UAC, this stands for user account control. I don't recommmend it as this is a vista security feature. But you can disable it, try FSX and see if that solves your problem, at least you'll know the cause.2: THis is what I do, I install FSX to some other directory besides C:/program files..such as C:/Microsoft Games/Flight Simulator or some such thing. I actually install to another partition entirely.3: If re-installing is not an option, you can take ownership of the Microsoft Games folder inside Program Files. Navigate to the folder "Microsoft Games" , right click on it and click properties, then slect the security tab. Look in the list of users below, find your user name, and check off allow on all the options. Then click OK. It will go through a rather long process of going through every file in the folder and assigning all rights to every file there. When it completes, restart your pc and try your controller settings again.This is just a shot in the dark but I was having a similar issue back when I first got Vista and it cured it for me. It could also be a hardware. OS or driver problem. Or a buggy install if FSX. But this is something to try.Good luck, Larry

Share this post


Link to post
Share on other sites

Dear Larry,Thanks for the pain you have taken. Unfortunately I have tried the third solution you suggest but it doesn't help at all. To answer your question: no it doesn't lose the assignments. What happens is the following: if I start with an airborne plane, it dives to the right and runs to the ground like a Messerscmidt at the onset of an attack. If I use a plane on the ground, it makes a right as well. However sometimes the calibration holds. I think it looks like the USB connection wouldn't wake up.What do you think?Regards.Armand.

Share this post


Link to post
Share on other sites
Dear Larry,Thanks for the pain you have taken. Unfortunately I have tried the third solution you suggest but it doesn't help at all. To answer your question: no it doesn't lose the assignments. What happens is the following: if I start with an airborne plane, it dives to the right and runs to the ground like a Messerscmidt at the onset of an attack. If I use a plane on the ground, it makes a right as well. However sometimes the calibration holds. I think it looks like the USB connection wouldn't wake up.What do you think?Regards.Armand.
Hi Armand,Have you tried it in any other game to see if it's the hardware? May download a flight demo somewhere and try it.Do you have any other controllers hooked up besides the yoke? Did you calibrate the yoke inside windows or FSX? Does the yoke have any software that needs to do the calibrating? I had the older yoke, it came with software but was not a requirement to use the yoke, all you needed were the windows drivers. Is this newer yoke the same?If you did install some kind of program along with the drivers, where did it install to? Is it running during your testing?If the USB port "goes to sleep" you could try disabling the power save function on the USB port. Go to your control panel then system, then device manager. Look in the list underneath USB Serial Controllers for every listing that says "USB Root Hub" Right click on each and select properties, then power management tab. "Uncheck" "allow the the computer to turn this device off to save power". Do this for evey listing of USB Root Hub in the device manager.Then reboot. If that doesn't help, see what kind of power requirements the Yoke has from the USB hub. I remember back when I got my Track IR that it was hogging more power than the hub was capable of producing. Quick fix was a USB hub with it's own power source.If the yoke requires USB 2.0 full speed, you could check in your bios to make sure it is turned on. Some boards default to 1.1 but there is a setting to change it to 2.0. Newer boards mostly are already set at 2.0.Can you try this yoke on another PC and see if it has the same issues there?What are your pc specs?Larry

Share this post


Link to post
Share on other sites

Hi Larry,Thanks once again for answering with so many details and useful suggestions. Actually I have detected and fixed the problem: in the CHCM (CH Products Control Manager) you must calibrate not only the yoke as such but also see to it that the axis settings are correct. Well, for whatever reason, one box corresponding to a particular axis had come unchecked, which caused the plane to turn right. After I checked it off again everything ran perfect and straight. This being done I will now implement your suggestion concerning the "going to sleep" of the device because that remains to be done, but it's a minor problem.Thanks a lot and happy New Year to you. Kind regards. Armand.

Share this post


Link to post
Share on other sites