Archived

This topic is now archived and is closed to further replies.

Guest Baltique

Problem With Md11 Fs9 And Fsuipc Version

Recommended Posts

Hi there,I am just wanting to see if I can get some help with my installation of the PMDG MD11 for FS9. In my hurry to get up and running I installed the MD11 before checking my FSUIPC version. While loading the plane in FS9 I got an PMDG error saying that my FSUPIC version is too old, and that I need one of at least version 3.81. OK - off I go to the web, download and install version 3.85 of FSUIPC (my version is registered). Only problem is that when I restart FS9 and try and load the MD11, I get the same FSUIPC error... Restarting the computer and even a re-installation of the MD11 have not helped. I have checked and the FSUIPC version in my modules folder is indeed 3.85, but I still get the error about a FSUIPC version that is too old! Any help out there for this issue??Karl Grigg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Further info - I just deleted my FSUIPC ini, so as to regenerate a new one - started up FS9 and then the MD11 - and the same error of a too old FSUIPC version popped up and closed down my sim......Re-downloaded from schirati.com version 3.85 and placed into the modules folder again - still no joy.....K. Grigg

Share this post


Link to post
Share on other sites
Further info - I just deleted my FSUIPC ini, so as to regenerate a new one - started up FS9 and then the MD11 - and the same error of a too old FSUIPC version popped up and closed down my sim......Re-downloaded from schirati.com version 3.85 and placed into the modules folder again - still no joy.....K. Griggi had the same problem,i deleted the fsuipc ini file made sure that there was only one fsuipc dll file and i have been flying ever sinceThanks to dan downs for that quick fix.sorry i cant be more helpnick b

Share this post


Link to post
Share on other sites

Thanks nick b,I have done a search on my computer - and there is only one fsuipc.dll on my machine and that is the version 3.85 in my modules folder. I have again deleted the fsuips ini file, but still the error of a too old fsuipc keeps reappearing when loading the MD11 and closing down the sim. Even worse, I have verified that the same thing is now happening with my PMDG 747-400 !!! even though I have never had any problems loading this plane before.The version number of my previous fsuipc version seems to be stuck somewhere in a file to do with PMDG planes, and it is not being updated by the new, more recent version currently in my modules folder. I have verified that my non PMDG planes load without a problem.Help PMDG!K.Grigg

Share this post


Link to post
Share on other sites

Hi guysI have the same problem as you guys. I tried a lot of times then I found a solution hope to help your guys.1.Delete the FSUIPC.KEY in your modules folder.2.Get a clean FSUIPC.KEY from your freinds or open this file with notepad and delete all the things,then add [Programs]PMDGOptions.DLL=CJM4KBNN1RLQsave and closeRun FS again then you will see MD11 works,after that register your fsuipc .If you have any problem please contact me via vivienne100428@hotmail.comWayne

Share this post


Link to post
Share on other sites
Thanks nick b,I have done a search on my computer - and there is only one fsuipc.dll on my machine and that is the version 3.85 in my modules folder. I have again deleted the fsuips ini file, but still the error of a too old fsuipc keeps reappearing when loading the MD11 and closing down the sim. Even worse, I have verified that the same thing is now happening with my PMDG 747-400 !!! even though I have never had any problems loading this plane before.The version number of my previous fsuipc version seems to be stuck somewhere in a file to do with PMDG planes, and it is not being updated by the new, more recent version currently in my modules folder. I have verified that my non PMDG planes load without a problem.Help PMDG!K.Grigg
Yeah,I find out that the cause of that problem is that I have a old registered FSUIPC in my computer,and when you install PMDG MD11,the install programme just replace the FSUIPC.dll with a new version and do nothing with the original key file,I'm not that good at computers so I do not know how the FSUIPC.DLL invoke the key file when you run FS,but I tried to delete the key file and restart FS,it works without any problems too.

Share this post


Link to post
Share on other sites

Thank you WayneWu,It seems my problem is the same as yours. I removed my fsuiupc.key from the modules folder, and finally I can load and use the MD-11 without the "fsuipc too old" error, but of course my fsuipc is now unregistered. I then go and re-register my copy of fsuipc (the version 3.85), close down FS, restart FS, load the MD-11, and "?

Share this post


Link to post
Share on other sites

Thanks,This does not however explain the "wierd" situation that when I have deleted the FSUIPC.key, the PMDGOptions.dll checks my running (but unregistered) FSUIPC and finds that it is okay, but that when I register exactly this same FSUIPC module (version 3.85), it decides that it is not okay and gives me the "fsuipc too old" error. I have certainly not added or deleted any additional FSUIPC modules to my system in between????Very odd indeed..... but a repeatable situation (trust me - I have tried it a few times now....)Flying for the moment with an unregistered FSUIPC and otherwise very impressed / happy with the MD-11 (and concerned about how I am going to fit all of the reading of manuals inbetween trying to work during the week, and going skiing on the weekend???)K. Grigg

Share this post


Link to post
Share on other sites

This worked for me - I just replaced the FSUIPC.dll file within ...\Modules\ASv6 with the updated version from the main modules folder. Just do a search and find all FSUIPC.dll files in your FS directory. Replace them all with the latest version and then register from within FS.Cheers,Keith

Share this post


Link to post
Share on other sites