Archived

This topic is now archived and is closed to further replies.

Guest roy13

saitek evo force

Recommended Posts

I have recently changed from a Saitek Evo joystick to an Evo Force joystick in FS 2004. Now all the planes load with a throttle problem. The full movement of the throttle lever only gives me from 1% to 99% thrust instead of 0% to 100%. The bottom setting makes taxiing difficult. Saitek tech support can`t help. Any ideas? RM.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have recently changed from a Saitek Evo joystick to an Evo Force joystick in FS 2004. Now all the planes load with a throttle problem. The full movement of the throttle lever only gives me from 1% to 99% thrust instead of 0% to 100%. The bottom setting makes taxiing difficult. Saitek tech support can`t help. Any ideas? RM.
Check your sensitivity and null settings in the flight sim. Sensitivity should be full right 100 and the null zone full left 0.Don't forget to calibrate the joystick in the sim ie via Windows. Using a different plane can upset the calibration.regardsPeterH

Share this post


Link to post
Share on other sites
Check your sensitivity and null settings in the flight sim. Sensitivity should be full right 100 and the null zone full left 0.Don't forget to calibrate the joystick in the sim ie via Windows. Using a different plane can upset the calibration.regardsPeterH

Share this post


Link to post
Share on other sites

Thanks for your suggestion but I have already checked those things. I have discovered that the problem is not just with addon Caravans but also with the default Caravan. There must be some sort of conflict between the Caravan software in FS and my joystick. When the plane first loads the throttle setting reads 0% but as soon as I move the joystick it will not go back to zero. I think I am stuck with the problem. Regards Roy.

Share this post


Link to post
Share on other sites
Thanks for your suggestion but I have already checked those things. I have discovered that the problem is not just with addon Caravans but also with the default Caravan. There must be some sort of conflict between the Caravan software in FS and my joystick. When the plane first loads the throttle setting reads 0% but as soon as I move the joystick it will not go back to zero. I think I am stuck with the problem. Regards Roy.
RoyAre you running the SST software? If so try it disabled and check in FSX that you do not have any duplicate axes assigned (including the keyboard and mouse). The sim can sometime revert to default axes if it thinks that something has changed.RegardsPeterH

Share this post


Link to post
Share on other sites