Archived

This topic is now archived and is closed to further replies.

Misha_K

SBuilder Scenery Doesn't Show

Recommended Posts

Hi guys, Have been working on an FS9 VFR scenery of Belgrade, given the glaring absence of anything useable for that area. I have created a fair number of custom objects with EOD, textured them and tested them and saved them as API Macros. I then tried placing them with SBuilder 2.05. In a first test only two the buildings showed but with wrong altitudes. In subsequent tests none of them showed. The bgl files are where they should be and my test scenery has the highest priority level. I'm at a loss as to why nothing is visible. Please help. Thanks in advance. Misha

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello Misha,The first thing that comes to my mind is - have you activated the SBuilder Scenery in the Scenery Library of FS9? Note that I am not working anymore with SBuilder 206. SBuilderX still supports API macros and ASD macros and if your only purpose is to generate BGLs for FS9 with those objects, you can use SBuilderX (I do not know if you have FSX). Another tip: try to find the SCASM file under the Tools/Work directory. If I remember correctly the BGL should also be found there (and copied, if you have set it up, to the target BGL folder).If you want you can send me one of the API files and I will be glad to test it in my system.Kind Regards,Luis

Share this post


Link to post
Share on other sites

Hi Luis,Scenery is registered in the library. Scasm is where it should be and the bgl file does get generated. But nothing shows. I will give SBuilderX a try. If I don't get it figured out in the next couple of hours I might send you a PM with the files. Thanks again. Misha

Share this post


Link to post
Share on other sites

Two more notes:The API macros show just fine in FS9 when I use EOD Preview. It is when I insert them using SBuilder that they don't want to show any more after initially showing up properly.Secondly, I just tried installing SBuilderX but it won't start up properly because it cannot find FSX on my system, which I don't have installed. HOw can I use SBuilderX without FSX?Misha

Share this post


Link to post
Share on other sites

Problem solved. I compiled each object into an individual bgl and now they all show. Selecting all and compiling into a single bgl didn't work.

Share this post


Link to post
Share on other sites
Problem solved. I compiled each object into an individual bgl and now they all show. Selecting all and compiling into a single bgl didn't work.
Hi,I am glad that you sorted it out. If you could be kind to send me by private email the SCASM file that SBuilder generates with 2 objects in the same file that do not show in FS9, I would appreciate. Kind Regards,Luis

Share this post


Link to post
Share on other sites

Luis, I'm afraid I have considerably moved on with the project and am no longer in a position to replicate that problem as the scenery has been significantly expanded and even the macros have changed. Sorry.Misha

Share this post


Link to post
Share on other sites